Richard Marian Thomaiyar | 14fddef | 2018-07-13 23:55:56 +0530 | [diff] [blame] | 1 | DESCRIPTION = "This is a small simple module which simplifies the \ |
| 2 | manipulation of @INC at compile time. It is typically used to add extra \ |
| 3 | directories to Perl's search path so that later 'use' or 'require' statements \ |
| 4 | will find modules which are not located in the default search path." |
| 5 | |
| 6 | SECTION = "libs" |
| 7 | LICENSE = "Artistic-1.0 | GPL-1.0+" |
| 8 | PR = "r0" |
| 9 | |
| 10 | LIC_FILES_CHKSUM = "file://README;beginline=26;endline=30;md5=94b119f1a7b8d611efc89b5d562a1a50" |
| 11 | |
| 12 | DEPENDS += "perl" |
| 13 | |
| 14 | SRC_URI = "http://www.cpan.org/authors/id/S/SM/SMUELLER/lib-${PV}.tar.gz" |
| 15 | |
| 16 | SRC_URI[md5sum] = "8607ac4e0d9d43585ec28312f52df67c" |
| 17 | SRC_URI[sha256sum] = "72f63db9220098e834d7a38231626bd0c9b802c1ec54a628e2df35f3818e5a00" |
| 18 | |
| 19 | S = "${WORKDIR}/lib-${PV}" |
| 20 | |
| 21 | EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}" |
| 22 | |
| 23 | inherit cpan |
| 24 | |
| 25 | do_compile() { |
| 26 | export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')" |
| 27 | cpan_do_compile |
| 28 | } |