blob: 4c0e37ebc72768084b70d4a40bfaca845439940a [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SECTION = "devel"
2SUMMARY = "Linux Trace Toolkit KERNEL MODULE"
3DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules"
4HOMEPAGE = "https://lttng.org/"
5LICENSE = "LGPL-2.1-only & GPL-2.0-only & MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=0464cff101a009c403cd2ed65d01d4c4"
7
8inherit module
9
10include lttng-platforms.inc
11
Patrick Williams03907ee2022-05-01 06:28:52 -050012SRC_URI = "https://lttng.org/files/${BPN}/${BPN}-${PV}.tar.bz2 \
Andrew Geissler615f2f12022-07-15 14:00:58 -050013 "
Patrick Williams03907ee2022-05-01 06:28:52 -050014
Andrew Geissler9aee5002022-03-30 16:27:02 +000015# Use :append here so that the patch is applied also when using devupstream
16SRC_URI:append = " file://0001-src-Kbuild-change-missing-CONFIG_TRACEPOINTS-to-warn.patch"
17
Andrew Geissler5082cc72023-09-11 08:41:39 -040018SRC_URI[sha256sum] = "13abfb1ac870711f0d0adfa88e53b17deb2e3052173715a260a6ef14aa45b0a7"
Andrew Geissler9aee5002022-03-30 16:27:02 +000019
20export INSTALL_MOD_DIR="kernel/lttng-modules"
21
22EXTRA_OEMAKE += "KERNELDIR='${STAGING_KERNEL_DIR}'"
23
24MODULES_MODULE_SYMVERS_LOCATION = "src"
25
26do_install:append() {
27 # Delete empty directories to avoid QA failures if no modules were built
28 if [ -d ${D}/${nonarch_base_libdir} ]; then
29 find ${D}/${nonarch_base_libdir} -depth -type d -empty -exec rmdir {} \;
30 fi
31}
32
33python do_package:prepend() {
34 if not os.path.exists(os.path.join(d.getVar('D'), d.getVar('nonarch_base_libdir')[1:], 'modules')):
35 bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN'))
36}
37
38BBCLASSEXTEND = "devupstream:target"
Andrew Geissler028142b2023-05-05 11:29:21 -050039SRC_URI:class-devupstream = "git://git.lttng.org/lttng-modules;branch=stable-2.13;protocol=https"
Andrew Geissler9aee5002022-03-30 16:27:02 +000040SRCREV:class-devupstream = "7584cfc04914cb0842a986e9808686858b9c8630"
41SRCREV_FORMAT ?= "lttng_git"