blob: e2c7a012c752f407042c38359748923f0579d5c9 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001DESCRIPTION = "Parole is a modern simple media player based on the GStreamer framework"
2HOMEPAGE = "https://docs.xfce.org/apps/parole/start"
3LICENSE = "GPL-2.0-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
5
6inherit xfce-app gtk-doc mime mime-xdg
7
8DEPENDS += " \
9 dbus-glib \
10 xfce4-dev-tools-native \
11 libxfce4util \
12 libxfce4ui \
13 xfconf \
14 \
15 gstreamer1.0-plugins-base \
16 taglib \
17"
18
19SRC_URI[sha256sum] = "bbe52fbc4d3abe30f6c79fc7ac57bd9de9cf74ce1a79b508a1d7de83dc4f3771"
20
21RDEPENDS:${PN} += "gstreamer1.0-plugins-good"
22
23EXTRA_OECONF = "--disable-gtk-doc DATADIRNAME=share"
24
25PACKAGECONFIG ??= "notify"
26PACKAGECONFIG[clutter] = "--enable-clutter, --disable-clutter, clutter"
27PACKAGECONFIG[notify] = "--enable-notify-plugin, --disable-notify-plugin, libnotify"
28
29FILES:${PN} += " \
30 ${datadir}/metainfo \
31 ${libdir}/parole-0/*.so \
32"