blob: 0942eeb15e7c4ef31ad5b9f53901ade1ebfad8f5 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Core utilities for Python packages"
2HOMEPAGE = "https://github.com/pypa/packaging"
3LICENSE = "Apache-2.0 | BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=faadaedca9251a90b205c9167578ce91"
5
Patrick Williams44b3caf2024-04-12 16:51:14 -05006SRC_URI[sha256sum] = "eb82c5e3e56209074766e6885bb04b8c38a0c015d0a30036ebe7ece34c9989e9"
Patrick Williamsac13d5f2023-11-24 18:59:46 -06007
8inherit pypi python_flit_core
9
10BBCLASSEXTEND = "native nativesdk"
11
12# Bootstrap the native build
13DEPENDS:remove:class-native = "python3-build-native"
14RDEPENDS:${PN} += "python3-profile"
15
16do_compile:class-native () {
17 python_flit_core_do_manual_build
18}