Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "Core utilities for Python packages" |
| 2 | HOMEPAGE = "https://github.com/pypa/packaging" |
| 3 | LICENSE = "Apache-2.0 | BSD-2-Clause" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=faadaedca9251a90b205c9167578ce91" |
| 5 | |
Patrick Williams | 44b3caf | 2024-04-12 16:51:14 -0500 | [diff] [blame] | 6 | SRC_URI[sha256sum] = "eb82c5e3e56209074766e6885bb04b8c38a0c015d0a30036ebe7ece34c9989e9" |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 7 | |
| 8 | inherit pypi python_flit_core |
| 9 | |
| 10 | BBCLASSEXTEND = "native nativesdk" |
| 11 | |
| 12 | # Bootstrap the native build |
| 13 | DEPENDS:remove:class-native = "python3-build-native" |
| 14 | RDEPENDS:${PN} += "python3-profile" |
| 15 | |
| 16 | do_compile:class-native () { |
| 17 | python_flit_core_do_manual_build |
| 18 | } |