Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | DESCRIPTION = "TinyALSA is a small library to interface with ALSA in \ |
| 2 | the Linux kernel. It is a lightweight alternative to libasound." |
| 3 | HOMEPAGE = "https://github.com/tinyalsa/tinyalsa" |
| 4 | SECTION = "libs/multimedia" |
| 5 | |
| 6 | LICENSE = "BSD-3-Clause" |
| 7 | LIC_FILES_CHKSUM = "file://NOTICE;md5=e04cd6fa58488e016f7fb648ebea1db4" |
| 8 | |
| 9 | SRCREV = "1c5fb68ced57d838f2b7ecd0c00bc1fefc9ab60d" |
| 10 | SRC_URI = "git://github.com/tinyalsa/tinyalsa;branch=master;protocol=https \ |
| 11 | file://0001-fixed-compilation-error-caused-by-strncpy.patch \ |
| 12 | " |
| 13 | |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | inherit cmake |
| 17 | |
| 18 | # tinyalsa is built as a static library. Enable PIC to avoid relocation |
| 19 | # errors like these: |
| 20 | # |
| 21 | # unresolvable R_AARCH64_ADR_PREL_PG_HI21 relocation against symbol `stderr@@GLIBC_2.17' |
| 22 | CFLAGS += " -fPIC -DPIC " |