Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "Shows and sets processor power related values" |
| 2 | DESCRIPTION = "cpupower is a collection of tools to examine and tune power \ |
| 3 | saving related features of your processor." |
| 4 | LICENSE = "GPLv2" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 6 | DEPENDS = "pciutils gettext-native" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 7 | PROVIDES = "virtual/cpupower" |
| 8 | |
| 9 | inherit kernelsrc kernel-arch |
| 10 | |
| 11 | do_populate_lic[depends] += "virtual/kernel:do_patch" |
| 12 | |
| 13 | EXTRA_OEMAKE = "-C ${S}/tools/power/cpupower O=${B} CROSS=${TARGET_PREFIX} CC="${CC}" LD="${LD}" AR=${AR} ARCH=${ARCH}" |
| 14 | |
| 15 | do_configure[depends] += "virtual/kernel:do_shared_workdir" |
| 16 | |
| 17 | do_compile() { |
| 18 | oe_runmake |
| 19 | } |
| 20 | |
| 21 | do_install() { |
| 22 | oe_runmake DESTDIR=${D} install |
| 23 | # Do not ship headers |
| 24 | rm -rf ${D}${includedir} |
| 25 | chown -R root:root ${D} |
| 26 | } |
| 27 | |
| 28 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
| 29 | |
| 30 | RDEPENDS_${PN} = "bash" |
| 31 | |
| 32 | python do_package_prepend() { |
| 33 | d.setVar('PKGV', d.getVar("KERNEL_VERSION", True).split("-")[0]) |
| 34 | } |
| 35 | |
| 36 | B = "${WORKDIR}/${BPN}-${PV}" |