Richard Marian Thomaiyar | 14fddef | 2018-07-13 23:55:56 +0530 | [diff] [blame] | 1 | SUMMARY = "Program radominization" |
| 2 | DESCRIPTION = "The checksec.sh script is designed to test what standard Linux OS and PaX security features are being used." |
| 3 | SECTION = "security" |
| 4 | LICENSE = "BSD" |
| 5 | HOMEPAGE="http://www.trapkit.de/tools/checksec.html" |
| 6 | |
| 7 | LIC_FILES_CHKSUM = "file://checksec.sh;md5=075996be339ab16ad7b94d6de3ee07bd" |
| 8 | |
| 9 | SRC_URI = "file://checksec.sh" |
| 10 | |
| 11 | S = "${WORKDIR}" |
| 12 | |
| 13 | do_install() { |
| 14 | install -d ${D}${bindir} |
| 15 | install -m 0755 ${WORKDIR}/checksec.sh ${D}${bindir} |
| 16 | } |
| 17 | |
| 18 | RDEPENDS_${PN} = "bash" |