Richard Marian Thomaiyar | 14fddef | 2018-07-13 23:55:56 +0530 | [diff] [blame] | 1 | SUMMARY = "Keynote tool and library" |
| 2 | DESCRIPTION = "KeyNote is a simple and flexible trust-management \ |
| 3 | system designed to work well for a variety of large- and small- \ |
| 4 | scale Internet-based applications. \ |
| 5 | " |
| 6 | HOMEPAGE = "http://www.cs.columbia.edu/~angelos/keynote.html" |
| 7 | SECTION = "security" |
| 8 | |
| 9 | LICENSE = "ISC" |
| 10 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3a265095c549c1808686a676f2699c98" |
| 11 | |
| 12 | MAIN_ID = "${@d.getVar('PV').split('.')[0]}" |
| 13 | MINOR_ID = "${@d.getVar('PV').split('.')[1]}" |
| 14 | SRC_URI = "${SOURCEFORGE_MIRROR}/project/${BPN}-${MAIN_ID}-${MINOR_ID}/${BPN}_${PV}.tar.gz \ |
| 15 | file://configure-remove-hardcode-path.patch \ |
| 16 | file://makefile-add-ldflags.patch \ |
| 17 | file://run-ptest \ |
| 18 | " |
| 19 | S = "${WORKDIR}/${BPN}-${PV}+dfsg.orig" |
| 20 | |
| 21 | inherit autotools-brokensep ptest |
| 22 | |
| 23 | SRC_URI[md5sum] = "a14553e6ad921b5c85026ce5bec3afe7" |
| 24 | SRC_URI[sha256sum] = "38d2acfa1c3630a07adcb5c8fe92d2aef7f0e6d242b8998b2bbb1c6e4c408d46" |
| 25 | |
| 26 | DEPENDS = "flex openssl" |
| 27 | |
| 28 | EXTRA_OEMAKE += "test-sample -j1" |
| 29 | |
| 30 | do_install() { |
| 31 | install -D -m 0755 ${S}/keynote ${D}${bindir}/keynote |
| 32 | install -D -m 0644 ${S}/libkeynote.a ${D}${libdir}/libkeynote.a |
| 33 | install -D -m 0644 ${S}/keynote.h ${D}${includedir}/keynote.h |
| 34 | } |
| 35 | |
| 36 | do_install_ptest() { |
| 37 | install -D -m 0755 ${S}/sample-app ${D}${PTEST_PATH} |
| 38 | cp -r ${S}/testsuite ${D}${PTEST_PATH} |
| 39 | sed -i 's|@PTEST_PATH@|${PTEST_PATH}|' ${D}${PTEST_PATH}/run-ptest |
| 40 | } |