blob: e2e82b32aa824bf12ce2de54259353364cc459c1 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "A thin layer of graphic data types"
2HOMEPAGE = "http://ebassi.github.io/graphene/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=a7d871d9e23c450c421a85bb2819f648"
5
Andrew Geissler517393d2023-01-13 08:55:19 -06006
7inherit gnomebase gobject-introspection gtk-doc
8
Andrew Geissler5082cc72023-09-11 08:41:39 -04009SRC_URI += "file://float-div.patch"
10
Andrew Geissler517393d2023-01-13 08:55:19 -060011SRC_URI[archive.sha256sum] = "a37bb0e78a419dcbeaa9c7027bcff52f5ec2367c25ec859da31dfde2928f279a"
12
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060013# Disable neon support by default on ARM-32 platforms because of the
14# following upstream bug: https://github.com/ebassi/graphene/issues/215
Patrick Williams8e7b46e2023-05-01 14:19:06 -050015PACKAGECONFIG ?= "gobject-types ${@bb.utils.contains('TUNE_FEATURES', 'aarch64', 'neon', '', d)}"
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060016
Patrick Williams8e7b46e2023-05-01 14:19:06 -050017PACKAGECONFIG[gobject-types] = "-Dgobject_types=true,-Dgobject_types=false,glib-2.0"
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060018PACKAGECONFIG[neon] = "-Darm_neon=true,-Darm_neon=false,"
19
20GIR_MESON_ENABLE_FLAG = 'enabled'
21GIR_MESON_DISABLE_FLAG = 'disabled'
Andrew Geissler517393d2023-01-13 08:55:19 -060022
23GTKDOC_MESON_OPTION = "gtk_doc"
24
25EXTRA_OEMESON = "-Dinstalled_tests=false"
26
27FILES:${PN} += "${libdir}/graphene-1.0"
28
29BBCLASSEXTEND = "native nativesdk"