Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | DESCRIPTION = "This package contains the Parser.pm module with friends." |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 2 | HOMEPAGE = "https://metacpan.org/release/HTML-Parser" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 3 | SECTION = "libs" |
| 4 | LICENSE = "Artistic-1.0 | GPL-1.0+" |
| 5 | |
| 6 | LIC_FILES_CHKSUM = "file://README;md5=b0459e4426b94753b9a9b8a15f1223b8" |
| 7 | |
| 8 | DEPENDS += "perl" |
| 9 | |
| 10 | SRC_URI = "http://search.cpan.org/CPAN/authors/id/G/GA/GAAS/HTML-Parser-${PV}.tar.gz" |
| 11 | |
| 12 | SRC_URI[md5sum] = "eb7505e5f626913350df9dd4a03d54a8" |
| 13 | SRC_URI[sha256sum] = "ec28c7e1d9e67c45eca197077f7cdc41ead1bb4c538c7f02a3296a4bb92f608b" |
| 14 | |
| 15 | S = "${WORKDIR}/HTML-Parser-${PV}" |
| 16 | |
| 17 | EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}" |
| 18 | |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 19 | inherit cpan ptest-perl |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 20 | |
| 21 | do_compile() { |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 22 | export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')" |
| 23 | cpan_do_compile |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 24 | } |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 25 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 26 | RDEPENDS:${PN} += "\ |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 27 | perl-module-exporter \ |
| 28 | perl-module-strict \ |
| 29 | perl-module-vars \ |
| 30 | perl-module-xsloader \ |
| 31 | libhtml-tagset-perl \ |
| 32 | " |
| 33 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 34 | RDEPENDS:${PN}-ptest += "\ |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 35 | liburi-perl \ |
| 36 | perl-module-config \ |
| 37 | perl-module-file-spec \ |
| 38 | perl-module-filehandle \ |
| 39 | perl-module-io-file \ |
| 40 | perl-module-selectsaver \ |
| 41 | perl-module-test \ |
| 42 | perl-module-test-more \ |
| 43 | " |
| 44 | |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 45 | BBCLASSEXTEND = "native" |