blob: 440259ffbd6c2776179a3aa7c676a32bb7817a3e [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "This is the io_uring library, liburing."
2DESCRIPTION = "liburing provides helpers to setup and teardown io_uring \
3instances, and also a simplified interface for applications that don't need \
4(or want) to deal with the full kernel side implementation."
5HOMEPAGE = "https://github.com/axboe/liburing"
6BUGTRACKER = "https://github.com/axboe/liburing/issues"
7SECTION = "libs"
8
Andrew Geissler9aee5002022-03-30 16:27:02 +00009LICENSE = "LGPL-2.1-only | MIT"
Andrew Geissler615f2f12022-07-15 14:00:58 -050010LIC_FILES_CHKSUM = "file://README;beginline=41;endline=44;md5=2b0e9926530c269f5ae95560370195af"
Andrew Geissler595f6302022-01-24 19:11:47 +000011
Patrick Williams03514f12024-04-05 07:04:11 -050012SRC_URI = "git://github.com/axboe/liburing.git;branch=master;protocol=https"
13SRCREV = "f4e42a515cd78c8c9cac2be14222834be5f8df2b"
Andrew Geissler595f6302022-01-24 19:11:47 +000014
15S = "${WORKDIR}/git"
16
17DEPENDS:append:libc-musl = " libucontext"
18XCFLAGS = "-pthread"
19XCFLAGS:append:libc-musl = " -lucontext"
20
21EXTRA_OEMAKE = "'CC=${CC}' 'RANLIB=${RANLIB}' 'AR=${AR}' 'CFLAGS=${CFLAGS} -I${S}/include -DWITHOUT_XATTR' 'LDFLAGS=${LDFLAGS}' 'XCFLAGS=${XCFLAGS}' 'BUILDDIR=${S}'"
22do_configure() {
Andrew Geissler9aee5002022-03-30 16:27:02 +000023 ${S}/configure --prefix=${prefix} --libdir=${libdir} --libdevdir=${libdir} --mandir=${mandir} --datadir=${datadir} --includedir=${includedir}
Andrew Geissler595f6302022-01-24 19:11:47 +000024}
25do_install () {
Andrew Geissler9aee5002022-03-30 16:27:02 +000026 oe_runmake install DESTDIR=${D}
Andrew Geissler595f6302022-01-24 19:11:47 +000027}
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060028
29BBCLASSEXTEND = "native nativesdk"