blob: e4c54bea9277eb871861fbf0ad4d80bd042c2bc2 [file] [log] [blame]
Brad Bishop5f9be072016-06-27 14:53:52 -04001SUMMARY = "org.openbmc.control.Host implementation for OpenPOWER"
2DESCRIPTION = "A host control implementation suitable for OpenPOWER systems."
3PR = "r1"
4
5inherit skeleton-gdbus
Brad Bishop1d525fa2016-08-17 20:27:37 -04006inherit obmc-phosphor-dbus-service
Brad Bishop5f9be072016-06-27 14:53:52 -04007
Sergey Solominaac4adf2016-11-28 15:03:24 -06008PROVIDES += "virtual/obmc-host-ctl"
9RPROVIDES_${PN} += "virtual-obmc-host-ctl"
10
Brad Bishop5f9be072016-06-27 14:53:52 -040011SKELETON_DIR = "op-hostctl"
Brad Bishop1d525fa2016-08-17 20:27:37 -040012
13FMT = "org.openbmc.control.Host@{0}.service"
14DBUS_SERVICE_${PN} += "${@compose_list(d, 'FMT', 'OBMC_HOST_INSTANCES')}"
Andrew Geissler238f3a72017-03-23 12:48:06 -050015SYSTEMD_SERVICE_${PN} = " \
16 op-start-host@.service \
Andrew Geissler238f3a72017-03-23 12:48:06 -050017 "
Brad Bishop1d525fa2016-08-17 20:27:37 -040018
19START_TMPL = "op-start-host@.service"
Josh D. Kingefb04a12017-04-06 15:56:37 -050020START_TGTFMT = "obmc-host-start@{1}.target"
Brad Bishop1d525fa2016-08-17 20:27:37 -040021START_INSTFMT = "obmc-start-host@{0}.service"
Andrew Geissler3c35a8c2017-02-08 15:54:25 -060022START_FMT = "../${START_TMPL}:${START_TGTFMT}.requires/${START_INSTFMT}"
Brad Bishop1d525fa2016-08-17 20:27:37 -040023
24SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'START_FMT', 'OBMC_HOST_INSTANCES', 'OBMC_CHASSIS_INSTANCES')}"