Richard Marian Thomaiyar | 14fddef | 2018-07-13 23:55:56 +0530 | [diff] [blame^] | 1 | SUMMARY = "Tripwire: A system integrity assessment tool (IDS)" |
| 2 | DESCRIPTION = "Open Source Tripwire® software is a security and data \ |
| 3 | integrity tool useful for monitoring and alerting on specific file change(s) on a range of systems" |
| 4 | HOMEPAGE="http://sourceforge.net/projects/tripwire" |
| 5 | SECTION = "security Monitor/Admin" |
| 6 | LICENSE = "GPLv2" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=1c069be8dbbe48e89b580ab4ed86c127" |
| 8 | |
| 9 | SRCREV = "80db91b4c1ca4be9efafd2286e3b2ad32ba4c34c" |
| 10 | |
| 11 | SRC_URI = "\ |
| 12 | git://github.com/Tripwire/tripwire-open-source.git \ |
| 13 | file://tripwire.cron \ |
| 14 | file://tripwire.sh \ |
| 15 | file://tripwire.txt \ |
| 16 | file://twcfg.txt \ |
| 17 | file://twinstall.sh \ |
| 18 | file://twpol-yocto.txt \ |
| 19 | " |
| 20 | |
| 21 | S = "${WORKDIR}/git" |
| 22 | |
| 23 | inherit autotools-brokensep update-rc.d |
| 24 | |
| 25 | INITSCRIPT_NAME = "tripwire" |
| 26 | INITSCRIPT_PARAMS = "start 40 S ." |
| 27 | TRIPWIRE_HOST = "${HOST_SYS}" |
| 28 | TRIPWIRE_TARGET = "${TARGET_SYS}" |
| 29 | |
| 30 | CXXFLAGS += "-fno-strict-aliasing" |
| 31 | EXTRA_OECONF = "--disable-openssl --enable-static --sysconfdir=/etc/tripwire" |
| 32 | |
| 33 | do_install () { |
| 34 | install -d ${D}${libdir} ${D}${datadir} ${D}${base_libdir} |
| 35 | install -d ${D}${sysconfdir} ${D}${mandir} ${D}${sbindir} |
| 36 | install -d ${D}${sysconfdir}/${PN} |
| 37 | install -d ${D}${localstatedir}/lib/${PN} ${D}${localstatedir}/lib/${BPN}/report |
| 38 | install -d ${D}${mandir}/man4 ${D}${mandir}/man5 ${D}${mandir}/man8 |
| 39 | install -d ${D}${docdir}/${BPN} ${D}${docdir}/${BPN}/templates |
| 40 | install -d ${D}${sysconfdir}/init.d |
| 41 | |
| 42 | install -m 0755 ${S}/bin/* ${D}${sbindir} |
| 43 | install -m 0644 ${S}/lib/* ${D}${base_libdir} |
| 44 | install -m 0644 ${S}/lib/* ${D}${localstatedir}/lib/${PN} |
| 45 | install -m 0755 ${WORKDIR}/tripwire.cron ${D}${sysconfdir} |
| 46 | install -m 0755 ${WORKDIR}/tripwire.sh ${D}${sysconfdir}/init.d/tripwire |
| 47 | install -m 0755 ${WORKDIR}/twinstall.sh ${D}${sysconfdir}/${PN} |
| 48 | install -m 0644 ${WORKDIR}/twpol-yocto.txt ${D}${sysconfdir}/${PN}/twpol.txt |
| 49 | install -m 0644 ${WORKDIR}/twcfg.txt ${D}${sysconfdir}/${PN} |
| 50 | |
| 51 | install -m 0644 ${S}/man/man4/* ${D}${mandir}/man4 |
| 52 | install -m 0644 ${S}/man/man5/* ${D}${mandir}/man5 |
| 53 | install -m 0644 ${S}/man/man8/* ${D}${mandir}/man8 |
| 54 | install -m 0644 ${S}/policy/templates/* ${D}${docdir}/${BPN}/templates |
| 55 | install -m 0644 ${S}/policy/*txt ${D}${docdir}/${BPN} |
| 56 | install -m 0644 ${S}/COPYING ${D}${docdir}/${BPN} |
| 57 | install -m 0644 ${S}/TRADEMARK ${D}${docdir}/${BPN} |
| 58 | install -m 0644 ${WORKDIR}/tripwire.txt ${D}${docdir}/${BPN} |
| 59 | } |
| 60 | |
| 61 | |
| 62 | FILES_${PN} += "${libdir} ${docdir}/${PN}/*" |
| 63 | FILES_${PN}-dbg += "${sysconfdir}/${PN}/.debug" |
| 64 | FILES_${PN}-staticdev += "${localstatedir}/lib/${PN}/lib*.a" |
| 65 | |
| 66 | RDEPENDS_${PN} += " perl nano msmtp cronie" |