Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "GNU All Mobile Managment Utilities" |
| 2 | SECTION = "console/network" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 3 | LICENSE = "GPL-2.0-only" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 5 | HOMEPAGE = "https://wammu.eu/" |
| 6 | |
| 7 | SRC_URI = "https://dl.cihar.com/${BPN}/releases/${BP}.tar.xz \ |
| 8 | file://gammurc \ |
| 9 | file://gammu-smsdrc \ |
| 10 | " |
| 11 | |
| 12 | SRC_URI[sha256sum] = "d8f152314d7e4d3d643610d742845e0a016ce97c234ad4b1151574e1b09651ee" |
| 13 | |
| 14 | UPSTREAM_CHECK_URI = "https://dl.cihar.com/${BPN}/releases" |
| 15 | |
| 16 | DEPENDS = "cmake-native virtual/libiconv libdbi mysql5 glib-2.0 udev libgudev unixodbc" |
| 17 | |
| 18 | inherit cmake gettext |
| 19 | |
| 20 | do_install:append() { |
| 21 | # these files seem to only be used by symbian and trigger QA warnings |
| 22 | rm -rf ${D}/usr/share/gammu |
| 23 | #install default configuration files |
| 24 | install -d ${D}${sysconfdir} |
| 25 | install -m 0644 ${WORKDIR}/gammurc ${D}${sysconfdir}/gammurc |
| 26 | install -m 0644 ${WORKDIR}/gammu-smsdrc ${D}${sysconfdir}/gammu-smsdrc |
| 27 | } |
| 28 | |
| 29 | EXTRA_OECONF = " \ |
| 30 | --enable-shared \ |
| 31 | --enable-backup \ |
| 32 | --enable-protection \ |
| 33 | " |
| 34 | |
| 35 | EXTRA_OECMAKE = " \ |
| 36 | -DWITH_CURL=OFF \ |
| 37 | -DWITH_BLUETOOTH=OFF \ |
| 38 | -DWITH_NOKIA_SUPPORT=OFF \ |
| 39 | -DWITH_IRDA=OFF \ |
| 40 | -DWITH_MySQL=ON \ |
| 41 | -DWITH_Postgres=OFF \ |
| 42 | " |
| 43 | |
| 44 | PACKAGES =+ "${PN}-smsd libgammu libgsmsd" |
| 45 | |
| 46 | FILES:${PN} = "${bindir}/gammu ${bindir}/jadmaker ${sysconfdir}/bash_completion.d/gammu \ |
| 47 | ${bindir}/gammu-detect ${sysconfdir}/gammurc" |
| 48 | CONFFILES:${PN} = "${sysconfdir}/gammurc" |
| 49 | FILES:${PN}-smsd = "${bindir}/gammu-smsd* ${sysconfdir}/gammu-smsdrc" |
| 50 | CONFFILES:${PN}-smsd = "${sysconfdir}/gammu-smsdrc" |
| 51 | FILES:${PN}-dev += "${bindir}/gammu-config ${libdir}/*.so" |
| 52 | FILES:${PN}-dbg += "${bindir}/.debug ${libdir}/.debug" |
| 53 | FILES:libgammu = "${libdir}/libGammu.so.*" |
| 54 | FILES:libgsmsd = "${libdir}/libgsmsd.so.*" |
| 55 | |
| 56 | RDEPENDS:${PN} += "bash" |
| 57 | RDEPENDS:${PN}-dev += "bash" |
| 58 | |
| 59 | # Fails to build with thumb-1 (qemuarm) |
| 60 | # gammu-1.32.0/libgammu/service/sms/gsmems.c:542:1: internal compiler error: in patch_jump_insn, at cfgrtl.c:1275 |
| 61 | # | } |
| 62 | # | ^ |
| 63 | # | Please submit a full bug report, |
| 64 | # | with preprocessed source if appropriate. |
| 65 | # | See <http://gcc.gnu.org/bugs.html> for instructions. |
| 66 | # | make[2]: *** [libgammu/CMakeFiles/libGammu.dir/service/sms/gsmems.o] Error 1 |
| 67 | # | make[2]: *** Waiting for unfinished jobs.... |
| 68 | ARM_INSTRUCTION_SET = "arm" |