blob: a5a7a636573960b426419221e5e5da7293d80c8c [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "A garbage collector for C and C++"
2
3DESCRIPTION = "The Boehm-Demers-Weiser conservative garbage collector can be\
4 used as a garbage collecting replacement for C malloc or C++ new. It allows\
5 you to allocate memory basically as you normally would, without explicitly\
6 deallocating memory that is no longer useful. The collector automatically\
7 recycles memory when it determines that it can no longer be otherwise\
8 accessed.\
9 The collector is also used by a number of programming language\
10 implementations that either use C as intermediate code, want to facilitate\
11 easier interoperation with C libraries, or just prefer the simple collector\
12 interface.\
13 Alternatively, the garbage collector may be used as a leak detector for C\
14 or C++ programs, though that is not its primary goal.\
15 Empirically, this collector works with most unmodified C programs, simply\
16 by replacing malloc with GC_malloc calls, replacing realloc with GC_realloc\
17 calls, and removing free calls."
18
Patrick Williamsb542dec2023-06-09 01:26:37 -050019HOMEPAGE = "https://www.hboehm.info/gc/"
Patrick Williams92b42cb2022-09-03 06:53:57 -050020SECTION = "devel"
21LICENSE = "MIT"
22LIC_FILES_CHKSUM = "file://README.QUICK;md5=dd27361ad00943bb27bc3e0589037075"
23
24DEPENDS = "libatomic-ops"
25
Patrick Williams73bd93f2024-02-20 08:07:48 -060026SRCREV = "e340b2e869e02718de9c9d7fa440ef4b35785388"
Patrick Williams92b42cb2022-09-03 06:53:57 -050027SRC_URI = "git://github.com/ivmai/bdwgc.git;branch=release-8_2;protocol=https"
28
29S = "${WORKDIR}/git"
30
31inherit autotools pkgconfig
32
Andrew Geissler87f5cff2022-09-30 13:13:31 -050033EXTRA_OECONF += "--enable-cplusplus"
Patrick Williams92b42cb2022-09-03 06:53:57 -050034
35FILES:${PN}-doc = "${datadir}"
36
37BBCLASSEXTEND = "native nativesdk"