blob: aec728640474289f1a068c670a29af9f540b17db [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Microsoft project for cloud-based client-server communication in native code using a modern asynchronous C++ API design."
2SECTION = "libs/network"
3HOMEPAGE = "https://github.com/Microsoft/cpprestsdk/"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://${S}/license.txt;md5=a2e15b954769218ff912468eecd6a02f"
6DEPENDS = "openssl websocketpp zlib boost brotli"
7
8EXTRA_OECMAKE = "-DCPPREST_EXPORT_DIR=cmake/cpprestsdk -DCPPREST_EXCLUDE_BROTLI=OFF -DWERROR=OFF"
9
10SRC_URI = "git://github.com/Microsoft/cpprestsdk.git;protocol=https;branch=master \
11 file://disable-float-tests.patch \
12 file://disable-outside-tests.patch "
13
Patrick Williams169d7bc2024-01-05 11:33:25 -060014# tag 2.10.19
15SRCREV= "411a109150b270f23c8c97fa4ec9a0a4a98cdecf"
Andrew Geissler82c905d2020-04-13 13:39:40 -050016
17S = "${WORKDIR}/git"
18
19inherit cmake pkgconfig