blob: df95df6f7077a594788b480a4a8d1ae73b51a424 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "The upstream project used to drive the Device Mapper multipathing driver"
2
3DESCRIPTION = "It provides tools to manage multipath devices \
4by instructing the device-mapper kernel module what to do. These \
5tools include: \
61. multipath - Scan the system for multipath devices and assemble them.\
72. multipathd - Detects when paths fail and execs multipath to update \
8things.\
93. mpathpersist - Persistent reservation management feature allows \
10cluster management software to manage persistent reservation through \
11mpath device. It processes management requests from callers and hides \
12the management task details. It also handles persistent reservation \
13management of data path life cycle and state changes.\
144. kpartx - This tool, derived from util-linux's partx, reads partition \
15tables on specified device and create device maps over partitions \
16segments detected. It is called from hotplug upon device maps creation \
17and deletion"
18
19HOMEPAGE = "http://christophe.varoqui.free.fr/"
20
21DEPENDS = "libdevmapper \
22 lvm2 \
23 libaio \
24 liburcu \
25 readline \
26 udev \
27 json-c \
28 "
29
30LICENSE = "GPL-2.0-only"
31
Patrick Williamsac13d5f2023-11-24 18:59:46 -060032SRC_URI = "git://github.com/opensvc/multipath-tools.git;protocol=https;branch=master \
Andrew Geissler517393d2023-01-13 08:55:19 -060033 file://multipathd.oe \
34 file://multipath.conf.example \
Patrick Williamsb58112e2024-03-07 11:16:36 -060035 file://0001-RH-fixup-udev-rules-for-redhat.patch \
36 file://0002-RH-Remove-the-property-blacklist-exception-builtin.patch \
37 file://0003-RH-don-t-start-without-a-config-file.patch \
38 file://0004-RH-use-rpm-optflags-if-present.patch \
39 file://0005-RH-add-mpathconf.patch \
40 file://0006-RH-add-wwids-from-kernel-cmdline-mpath.wwids-with-A.patch \
41 file://0007-RH-warn-on-invalid-regex-instead-of-failing.patch \
42 file://0008-RH-reset-default-find_mutipaths-value-to-off.patch \
43 file://0009-multipath-tools-modify-create-config.mk-for-cross-co.patch \
44 file://0010-Subject-PATCH-Always-use-devmapper.patch \
45 file://0011-fix-bug-of-do_compile-and-do_install.patch \
46 file://0012-add-explicit-dependency-on-libraries.patch \
Andrew Geissler517393d2023-01-13 08:55:19 -060047 "
48
49LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
50
Patrick Williamsb58112e2024-03-07 11:16:36 -060051SRCREV = "3daacfdfd110b24a3a7d5a276dcf8512b7039199"
Andrew Geissler517393d2023-01-13 08:55:19 -060052
53S = "${WORKDIR}/git"
54
55inherit systemd pkgconfig
56
57SYSTEMD_SERVICE:${PN} = "multipathd.service"
58SYSTEMD_AUTO_ENABLE = "disable"
59
60TARGET_CC_ARCH += "${LDFLAGS}"
61
62# multipath-tools includes a copy of the valgrind.h header
63# file and uses the macros to suppress some false positives. However,
64# that only works on ARM when thumb is disabled. Otherwise one gets:
65# Error: shifts in CMP/MOV instructions are only supported in unified syntax -- `mov r12,r12,ror#3'
66# ../Makefile.inc:66: recipe for target 'debug.o' failed
67ARM_INSTRUCTION_SET:armv4 = "arm"
68ARM_INSTRUCTION_SET:armv5 = "arm"
69
70# The exact version of SYSTEMD does not matter but should be greater than 209.
71#
72EXTRA_OEMAKE = 'MULTIPATH_VERSION=${PV} DESTDIR=${D} syslibdir=${base_libdir} \
73 OPTFLAGS="${CFLAGS}" \
74 prefix=${prefix} \
75 bindir=${base_sbindir} \
76 LIB=${base_libdir} libdir=${base_libdir}/multipath \
77 usrlibdir=${libdir} \
78 plugindir=${base_libdir}/multipath \
79 unitdir=${systemd_system_unitdir} \
80 libudevdir=${nonarch_base_libdir}/udev \
81 modulesloaddir=${sysconfdir}/modules-load.d \
82 tmpfilesdir=${sysconfdir}/tmpfiles.d \
83 ${@bb.utils.contains("DISTRO_FEATURES", "systemd", "SYSTEMD=216", "", d)} \
84 '
85
86do_install() {
87 oe_runmake install
88
89 # We copy an initscript, but do not start multipathd at init time.
90 #
91 if ${@bb.utils.contains('DISTRO_FEATURES','sysvinit','true','false',d)};then
92 install -d ${D}${sysconfdir}/init.d
93 cp ${WORKDIR}/multipathd.oe ${D}${sysconfdir}/init.d/multipathd
94 fi
95
96 sed -i "s:/usr/lib/udev/kpartx_id:${nonarch_base_libdir}/udev/kpartx_id:g" \
97 ${D}${nonarch_base_libdir}/udev/rules.d/11-dm-mpath.rules
98
99 install -d ${D}${sysconfdir}
100 install -m 0644 ${WORKDIR}/multipath.conf.example \
101 ${D}${sysconfdir}/multipath.conf.example
102}
103
Patrick Williamsb58112e2024-03-07 11:16:36 -0600104FILES:${PN} += "${systemd_system_unitdir}"
Andrew Geissler517393d2023-01-13 08:55:19 -0600105FILES:${PN}-dbg += "${base_libdir}/multipath/.debug"
106
107PACKAGES =+ "${PN}-libs"
108FILES:${PN}-libs = "${base_libdir}/lib*.so.* \
109 ${base_libdir}/multipath/lib*.so*"
110RDEPENDS:${PN} += "${PN}-libs bash libgcc"
111
112PROVIDES += "device-mapper-multipath"
113RPROVIDES:${PN} += "device-mapper-multipath"
114RPROVIDES:${PN}-libs += "device-mapper-multipath-libs"
115
116FILES:${PN}-dev += "${base_libdir}/pkgconfig"
117
118PACKAGES =+ "kpartx"
119FILES:kpartx = "${base_sbindir}/kpartx \
120 ${nonarch_base_libdir}/udev/kpartx_id \
121 "
122
123RDEPENDS:${PN} += "kpartx"
124PARALLEL_MAKE = ""