Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "File system QA test suite" |
| 2 | LICENSE = "GPL-2.0-only" |
| 3 | LIC_FILES_CHKSUM = "file://LICENSES/GPL-2.0;md5=74274e8a218423e49eefdea80bc55038" |
| 4 | |
Patrick Williams | 03514f1 | 2024-04-05 07:04:11 -0500 | [diff] [blame] | 5 | SRCREV = "088e5bd4cb6d7295612430a56ae84ff5c8f54730" |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 6 | SRCREV_unionmount = "e3825b16b46f4c4574a1a69909944c059835f914" |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 7 | SRCREV_FORMAT = "default_unionmount" |
| 8 | |
| 9 | SRC_URI = "git://git.kernel.org/pub/scm/fs/xfs/xfstests-dev.git;branch=master \ |
| 10 | git://github.com/amir73il/unionmount-testsuite.git;branch=master;protocol=https;name=unionmount;destsuffix=unionmount-testsuite \ |
| 11 | file://0001-add-missing-FTW_-macros-when-not-available-in-libc.patch \ |
| 12 | file://0002-Drop-detached_mounts_propagation-and-remove-sys-moun.patch \ |
Patrick Williams | 03514f1 | 2024-04-05 07:04:11 -0500 | [diff] [blame] | 13 | file://0001-include-libgen.h-for-basename-API-prototype.patch \ |
| 14 | file://0002-Add-missing-STATX_ATTR_-defines-from-musl-sys-stat.h.patch \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 15 | " |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 16 | |
| 17 | S = "${WORKDIR}/git" |
| 18 | |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 19 | # brokensep because m4/package_globals.m4 calls ". ./VERSION" (and that's not the only issue) |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 20 | inherit autotools-brokensep useradd |
| 21 | |
| 22 | DEPENDS += "xfsprogs acl" |
| 23 | RDEPENDS:${PN} += "\ |
| 24 | bash \ |
| 25 | bc \ |
| 26 | coreutils \ |
| 27 | e2fsprogs \ |
| 28 | e2fsprogs-tune2fs \ |
| 29 | e2fsprogs-resize2fs \ |
| 30 | libaio \ |
| 31 | libcap-bin \ |
| 32 | overlayfs-tools \ |
| 33 | perl \ |
| 34 | python3 \ |
| 35 | python3-core \ |
| 36 | xfsprogs \ |
| 37 | acl \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 38 | gawk \ |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 39 | " |
| 40 | |
| 41 | USERADD_PACKAGES = "${PN}" |
| 42 | # these users are necessary to run the tests |
| 43 | USERADD_PARAM:${PN} = "-U -m fsgqa; -N 123456-fsgqa; -N fsgqa2" |
| 44 | |
| 45 | EXTRA_OECONF = "INSTALL_USER=root INSTALL_GROUP=root" |
| 46 | |
| 47 | TARGET_CC_ARCH:append:libc-musl = " -D_LARGEFILE64_SOURCE" |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 48 | |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 49 | do_configure:prepend() { |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 50 | # this is done by Makefile configure target, but we don't call it in do_configure |
| 51 | cp -a ${S}/include/install-sh . |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 52 | } |
| 53 | |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 54 | do_install() { |
| 55 | # otherwise install-sh duplicates DESTDIR prefix |
| 56 | export DIST_ROOT="/" DIST_MANIFEST="" DESTDIR="${D}" |
| 57 | oe_runmake install |
| 58 | |
| 59 | unionmount_target_dir=${D}${prefix}/xfstests/unionmount-testsuite |
| 60 | install -d $unionmount_target_dir/tests |
| 61 | install ${WORKDIR}/unionmount-testsuite/tests/* -t $unionmount_target_dir/tests |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 62 | install ${WORKDIR}/unionmount-testsuite/*.py -t $unionmount_target_dir |
| 63 | install ${WORKDIR}/unionmount-testsuite/run -t $unionmount_target_dir |
| 64 | install ${WORKDIR}/unionmount-testsuite/README -t $unionmount_target_dir |
| 65 | } |
| 66 | |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 67 | FILES:${PN} += "${prefix}/xfstests" |