blob: e3555e1e463785164ba12cae90fc165f6dad3023 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001#
2# Copyright OpenEmbedded Contributors
3#
4# SPDX-License-Identifier: MIT
5#
6
7BUILD_GOOS = "${@go_map_os(d.getVar('BUILD_OS'), d)}"
8BUILD_GOARCH = "${@go_map_arch(d.getVar('BUILD_ARCH'), d)}"
9BUILD_GOTUPLE = "${BUILD_GOOS}_${BUILD_GOARCH}"
10HOST_GOOS = "${@go_map_os(d.getVar('HOST_OS'), d)}"
11HOST_GOARCH = "${@go_map_arch(d.getVar('HOST_ARCH'), d)}"
12HOST_GOARM = "${@go_map_arm(d.getVar('HOST_ARCH'), d)}"
13HOST_GO386 = "${@go_map_386(d.getVar('HOST_ARCH'), d.getVar('TUNE_FEATURES'), d)}"
14HOST_GOMIPS = "${@go_map_mips(d.getVar('HOST_ARCH'), d.getVar('TUNE_FEATURES'), d)}"
15HOST_GOARM:class-native = "7"
16HOST_GO386:class-native = "sse2"
17HOST_GOMIPS:class-native = "hardfloat"
18HOST_GOTUPLE = "${HOST_GOOS}_${HOST_GOARCH}"
19TARGET_GOOS = "${@go_map_os(d.getVar('TARGET_OS'), d)}"
20TARGET_GOARCH = "${@go_map_arch(d.getVar('TARGET_ARCH'), d)}"
21TARGET_GOARM = "${@go_map_arm(d.getVar('TARGET_ARCH'), d)}"
22TARGET_GO386 = "${@go_map_386(d.getVar('TARGET_ARCH'), d.getVar('TUNE_FEATURES'), d)}"
23TARGET_GOMIPS = "${@go_map_mips(d.getVar('TARGET_ARCH'), d.getVar('TUNE_FEATURES'), d)}"
24TARGET_GOARM:class-native = "7"
25TARGET_GO386:class-native = "sse2"
26TARGET_GOMIPS:class-native = "hardfloat"
27TARGET_GOTUPLE = "${TARGET_GOOS}_${TARGET_GOARCH}"
28GO_BUILD_BINDIR = "${@['bin/${HOST_GOTUPLE}','bin'][d.getVar('BUILD_GOTUPLE') == d.getVar('HOST_GOTUPLE')]}"
29
30# Use the MACHINEOVERRIDES to map ARM CPU architecture passed to GO via GOARM.
31# This is combined with *_ARCH to set HOST_GOARM and TARGET_GOARM.
32BASE_GOARM = ''
33BASE_GOARM:armv7ve = '7'
34BASE_GOARM:armv7a = '7'
35BASE_GOARM:armv6 = '6'
36BASE_GOARM:armv5 = '5'
37
38# Go supports dynamic linking on a limited set of architectures.
39# See the supportsDynlink function in go/src/cmd/compile/internal/gc/main.go
40GO_DYNLINK = ""
41GO_DYNLINK:arm ?= "1"
42GO_DYNLINK:aarch64 ?= "1"
43GO_DYNLINK:x86 ?= "1"
44GO_DYNLINK:x86-64 ?= "1"
45GO_DYNLINK:powerpc64 ?= "1"
46GO_DYNLINK:powerpc64le ?= "1"
47GO_DYNLINK:class-native ?= ""
48GO_DYNLINK:class-nativesdk = ""
49
50# define here because everybody inherits this class
51#
52COMPATIBLE_HOST:linux-gnux32 = "null"
53COMPATIBLE_HOST:linux-muslx32 = "null"
54COMPATIBLE_HOST:powerpc = "null"
55COMPATIBLE_HOST:powerpc64 = "null"
56COMPATIBLE_HOST:mipsarchn32 = "null"
57
58ARM_INSTRUCTION_SET:armv4 = "arm"
59ARM_INSTRUCTION_SET:armv5 = "arm"
60ARM_INSTRUCTION_SET:armv6 = "arm"
61
62TUNE_CCARGS:remove = "-march=mips32r2"
63SECURITY_NOPIE_CFLAGS ??= ""
64
65# go can't be built with ccache:
66# gcc: fatal error: no input files
67CCACHE_DISABLE ?= "1"
68
69def go_map_arch(a, d):
70 import re
71 if re.match('i.86', a):
72 return '386'
73 elif a == 'x86_64':
74 return 'amd64'
75 elif re.match('arm.*', a):
76 return 'arm'
77 elif re.match('aarch64.*', a):
78 return 'arm64'
79 elif re.match('mips64el.*', a):
80 return 'mips64le'
81 elif re.match('mips64.*', a):
82 return 'mips64'
83 elif a == 'mips':
84 return 'mips'
85 elif a == 'mipsel':
86 return 'mipsle'
87 elif re.match('p(pc|owerpc)(64le)', a):
88 return 'ppc64le'
89 elif re.match('p(pc|owerpc)(64)', a):
90 return 'ppc64'
91 elif a == 'riscv64':
92 return 'riscv64'
Andrew Geissler5082cc72023-09-11 08:41:39 -040093 elif a == 'loongarch64':
94 return 'loong64'
Patrick Williams92b42cb2022-09-03 06:53:57 -050095 else:
96 raise bb.parse.SkipRecipe("Unsupported CPU architecture: %s" % a)
97
98def go_map_arm(a, d):
99 if a.startswith("arm"):
100 return d.getVar('BASE_GOARM')
101 return ''
102
103def go_map_386(a, f, d):
104 import re
105 if re.match('i.86', a):
106 if ('core2' in f) or ('corei7' in f):
107 return 'sse2'
108 else:
109 return 'softfloat'
110 return ''
111
112def go_map_mips(a, f, d):
113 import re
114 if a == 'mips' or a == 'mipsel':
115 if 'fpu-hard' in f:
116 return 'hardfloat'
117 else:
118 return 'softfloat'
119 return ''
120
121def go_map_os(o, d):
122 if o.startswith('linux'):
123 return 'linux'
124 return o