Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Python bindings for the DBus inter-process communication system" |
| 2 | SECTION = "devel/python" |
| 3 | HOMEPAGE = "http://www.freedesktop.org/Software/dbus" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=b03240518994df6d8c974675675e5ca4" |
Brad Bishop | 96ff198 | 2019-08-19 13:50:42 -0400 | [diff] [blame] | 6 | DEPENDS = "expat dbus glib-2.0 virtual/libintl" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 7 | |
Brad Bishop | a34c030 | 2019-09-23 22:34:48 -0400 | [diff] [blame] | 8 | SRC_URI = "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-${PV}.tar.gz" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 9 | |
Brad Bishop | a34c030 | 2019-09-23 22:34:48 -0400 | [diff] [blame] | 10 | SRC_URI[md5sum] = "428b7a9e7e2d154a7ceb3e13536283e4" |
| 11 | SRC_URI[sha256sum] = "cdd4de2c4f5e58f287b12013ed7b41dee81d503c8d0d2397c5bd2fb01badf260" |
| 12 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 13 | S = "${WORKDIR}/dbus-python-${PV}" |
| 14 | |
| 15 | inherit distutils3-base autotools pkgconfig |
| 16 | |
| 17 | # documentation needs python3-sphinx, which is not in oe-core or meta-python for now |
| 18 | # change to use PACKAGECONFIG when python3-sphinx is added to oe-core |
| 19 | EXTRA_OECONF += "--disable-documentation" |
| 20 | |
| 21 | |
| 22 | RDEPENDS_${PN} = "python3-io python3-logging python3-stringold python3-threading python3-xml" |
| 23 | |
| 24 | FILES_${PN}-dev += "${libdir}/pkgconfig" |
Brad Bishop | 08902b0 | 2019-08-20 09:16:51 -0400 | [diff] [blame] | 25 | |
| 26 | BBCLASSEXTEND = "native nativesdk" |