Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 1 | SUMMARY = "Python library used to interact with Git repositories" |
| 2 | DESCRIPTION = "GitPython provides object model read and write access to \ |
| 3 | a git repository. Access repository information conveniently, alter the \ |
| 4 | index directly, handle remotes, or go down to low-level object database \ |
| 5 | access with big-files support." |
| 6 | HOMEPAGE = "http://github.com/gitpython-developers/GitPython" |
| 7 | SECTION = "devel/python" |
| 8 | LICENSE = "BSD-3-Clause" |
| 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=8b8d26c37c1d5a04f9b0186edbebc183" |
| 10 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 11 | PYPI_PACKAGE = "GitPython" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 12 | |
Brad Bishop | 08902b0 | 2019-08-20 09:16:51 -0400 | [diff] [blame] | 13 | inherit pypi setuptools3 |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 14 | |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 15 | SRC_URI[md5sum] = "ccec14a5c9f18702406122983d80032c" |
| 16 | SRC_URI[sha256sum] = "d2f4945f8260f6981d724f5957bc076398ada55cb5d25aaee10108bcdc894100" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 17 | |
Brad Bishop | 08902b0 | 2019-08-20 09:16:51 -0400 | [diff] [blame] | 18 | DEPENDS += " ${PYTHON_PN}-gitdb" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 19 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 20 | RDEPENDS_${PN} += " \ |
| 21 | ${PYTHON_PN}-datetime \ |
| 22 | ${PYTHON_PN}-gitdb \ |
| 23 | ${PYTHON_PN}-io \ |
| 24 | ${PYTHON_PN}-logging \ |
| 25 | ${PYTHON_PN}-math \ |
| 26 | ${PYTHON_PN}-netclient \ |
| 27 | ${PYTHON_PN}-stringold \ |
| 28 | ${PYTHON_PN}-unittest \ |
| 29 | ${PYTHON_PN}-unixadmin \ |
| 30 | git \ |
| 31 | " |
Brad Bishop | 08902b0 | 2019-08-20 09:16:51 -0400 | [diff] [blame] | 32 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 33 | BBCLASSEXTEND = "native nativesdk" |