blob: 452e1e65ab121c981e90187a3b7d380a7328e266 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Memory Efficient Serialization Library"
2HOMEPAGE = "https://github.com/google/flatbuffers"
3SECTION = "console/tools"
4LICENSE = "Apache-2.0"
5
6PACKAGE_BEFORE_PN = "${PN}-compiler"
7
8RDEPENDS_${PN}-compiler = "${PN}"
9RDEPENDS_${PN}-dev += "${PN}-compiler"
10
11LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=a873c5645c184d51e0f9b34e1d7cf559"
12
13SRCREV = "c0698cc33f1e534bb59c455909b88cc2726089af"
14
15SRC_URI = "git://github.com/google/flatbuffers.git"
16
17# Make sure C++11 is used, required for example for GCC 4.9
18CXXFLAGS += "-std=c++11"
19BUILD_CXXFLAGS += "-std=c++11"
20
21# BUILD_TYPE=Release is required, otherwise flatc is not installed
22EXTRA_OECMAKE += "\
23 -DCMAKE_BUILD_TYPE=Release \
24 -DFLATBUFFERS_BUILD_TESTS=OFF \
25 -DFLATBUFFERS_BUILD_SHAREDLIB=ON \
26"
27
28inherit cmake
29
30S = "${WORKDIR}/git"
31
32FILES_${PN}-compiler = "${bindir}"
33
34BBCLASSEXTEND = "native nativesdk"