Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "An HTTP library implementation in C" |
| 2 | HOMEPAGE = "https://wiki.gnome.org/Projects/libsoup" |
| 3 | BUGTRACKER = "https://bugzilla.gnome.org/" |
| 4 | SECTION = "x11/gnome/libs" |
| 5 | LICENSE = "LGPLv2" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2" |
| 7 | |
| 8 | DEPENDS = "glib-2.0 glib-2.0-native libxml2 sqlite3 intltool-native libpsl" |
| 9 | |
| 10 | SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}" |
| 11 | |
| 12 | SRC_URI = "${GNOME_MIRROR}/libsoup/${SHRT_VER}/libsoup-${PV}.tar.xz \ |
| 13 | file://0001-Do-not-enforce-no-introspection-when-cross-building.patch \ |
| 14 | " |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame^] | 15 | SRC_URI[md5sum] = "66c2ae89d6031b01337d78a2c57c75d5" |
| 16 | SRC_URI[sha256sum] = "bd2ea602eba642509672812f3c99b77cbec2f3de02ba1cc8cb7206bf7de0ae2a" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 17 | |
| 18 | S = "${WORKDIR}/libsoup-${PV}" |
| 19 | |
| 20 | inherit meson gettext pkgconfig upstream-version-is-even gobject-introspection gtk-doc |
| 21 | |
| 22 | # libsoup-gnome is entirely deprecated and just stubs in 2.42 onwards. Disable by default. |
| 23 | PACKAGECONFIG ??= "" |
| 24 | PACKAGECONFIG[gnome] = "-Dgnome=true,-Dgnome=false" |
| 25 | PACKAGECONFIG[gssapi] = "-Dgssapi=true,-Dgssapi=false,krb5" |
| 26 | |
| 27 | EXTRA_OEMESON_append = " -Dvapi=false" |
| 28 | |
| 29 | GTKDOC_MESON_OPTION = "doc" |
| 30 | |
| 31 | # When built without gnome support, libsoup-2.4 will contain only one shared lib |
| 32 | # and will therefore become subject to renaming by debian.bbclass. Prevent |
| 33 | # renaming in order to keep the package name consistent regardless of whether |
| 34 | # gnome support is enabled or disabled. |
| 35 | DEBIAN_NOAUTONAME_${PN} = "1" |
| 36 | |
| 37 | # glib-networking is needed for SSL, proxies, etc. |
| 38 | RRECOMMENDS_${PN} = "glib-networking" |