blob: a98be4af1be1f9588a60006f54e1a551448d565a [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001# This recipe is for bootstrapping our go-cross from a prebuilt binary of Go from golang.org.
2
3SUMMARY = "Go programming language compiler (upstream binary for bootstrap)"
4HOMEPAGE = " http://golang.org/"
5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=5d4950ecb7b26d2c5e4e7b4e0dd74707"
7
8PROVIDES = "go-native"
9
10# Checksums available at https://go.dev/dl/
11SRC_URI = "https://dl.google.com/go/go${PV}.${BUILD_GOOS}-${BUILD_GOARCH}.tar.gz;name=go_${BUILD_GOTUPLE}"
Patrick Williams520786c2023-06-25 16:20:36 -050012SRC_URI[go_linux_amd64.sha256sum] = "d7ec48cde0d3d2be2c69203bc3e0a44de8660b9c09a6e85c4732a3f7dc442612"
13SRC_URI[go_linux_arm64.sha256sum] = "aa2fab0a7da20213ff975fa7876a66d47b48351558d98851b87d1cfef4360d09"
14SRC_URI[go_linux_ppc64le.sha256sum] = "049b8ab07d34077b90c0642138e10207f6db14bdd1743ea994a21e228f8ca53d"
Andrew Geissler517393d2023-01-13 08:55:19 -060015
16UPSTREAM_CHECK_URI = "https://golang.org/dl/"
17UPSTREAM_CHECK_REGEX = "go(?P<pver>\d+(\.\d+)+)\.linux"
18
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050019CVE_PRODUCT = "go"
20
Andrew Geissler517393d2023-01-13 08:55:19 -060021S = "${WORKDIR}/go"
22
23inherit goarch native
24
25do_compile() {
26 :
27}
28
29make_wrapper() {
30 rm -f ${D}${bindir}/$1
31 cat <<END >${D}${bindir}/$1
32#!/bin/bash
33here=\`dirname \$0\`
34export GOROOT="${GOROOT:-\`readlink -f \$here/../lib/go\`}"
35\$here/../lib/go/bin/$1 "\$@"
36END
37 chmod +x ${D}${bindir}/$1
38}
39
40do_install() {
41 find ${S} -depth -type d -name testdata -exec rm -rf {} +
42
43 install -d ${D}${bindir} ${D}${libdir}/go
44 cp --preserve=mode,timestamps -R ${S}/ ${D}${libdir}/
45
46 for f in ${S}/bin/*
47 do
48 make_wrapper `basename $f`
49 done
50}