Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "Portable Hardware Locality (hwloc) software package" |
| 2 | DESCRIPTION = "The Portable Hardware Locality (hwloc) software package \ |
| 3 | provides a portable abstraction of the hierarchical topology of modern \ |
| 4 | architectures." |
| 5 | HOMEPAGE = "https://www.open-mpi.org/software/hwloc/" |
| 6 | SECTION = "base" |
| 7 | LICENSE = "BSD-3-Clause" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=79179bb373cd55cbd834463a514fb714" |
| 9 | |
| 10 | SRC_URI = "https://www.open-mpi.org/software/${BPN}/v2.9/downloads/${BP}.tar.bz2" |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 11 | SRC_URI[sha256sum] = "7cc4931a20fef457e0933af3f375be6eafa7703fde21e137bfb9685b1409599e" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 12 | UPSTREAM_CHECK_URI = "https://www.open-mpi.org/software/hwloc/v2.9/" |
| 13 | |
| 14 | inherit autotools bash-completion pkgconfig |
| 15 | |
| 16 | DEPENDS += "ncurses udev zlib" |
| 17 | DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'selinux', 'libselinux', '', d)}" |
| 18 | |
| 19 | PACKAGECONFIG ?= "pci libxml2 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}" |
| 20 | |
| 21 | PACKAGECONFIG[libxml2] = "--enable-libxml2,--disable-libxml2,libxml2,libxml2" |
| 22 | PACKAGECONFIG[x11] = "--with-x,--without-x,virtual/libx11 cairo,cairo" |
| 23 | PACKAGECONFIG[pci] = "--enable-pci,--disable-pci,libpciaccess,libpciaccess" |
| 24 | |
| 25 | # Split hwloc library into separate subpackage |
| 26 | PACKAGES:prepend = " libhwloc " |
| 27 | FILES:libhwloc += "${libdir}/libhwloc.so.*" |
| 28 | RDEPENDS:${PN} += "libhwloc (= ${EXTENDPKGV})" |