Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "ImageMagick is an image conversion toolkit" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 2 | SECTION = "console/utils" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 3 | HOMEPAGE = "https://www.imagemagick.org/" |
| 4 | DESCRIPTION = "ImageMagick is a collection of tools for displaying, converting, and \ |
| 5 | editing raster and vector image files. It can read and write over 200 image file formats." |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 6 | LICENSE = "ImageMagick" |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=ac58ac14f9d9d02cafd2d81ef38fb2cc \ |
| 8 | file://NOTICE;md5=bcbf1f1897b40ec8df39700cb560e9ed" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 9 | # FIXME: There are many more checked libraries. All should be added or explicitly disabled to get consistent results. |
Brad Bishop | 34ae600 | 2019-04-08 15:21:03 -0400 | [diff] [blame] | 10 | DEPENDS = "lcms bzip2 jpeg libpng tiff zlib fftw freetype libtool" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 11 | |
| 12 | BASE_PV := "${PV}" |
Andrew Geissler | 3eeda90 | 2023-05-19 10:14:02 -0500 | [diff] [blame] | 13 | PV .= "-8" |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 14 | SRC_URI = "git://github.com/ImageMagick/ImageMagick.git;branch=main;protocol=https \ |
| 15 | file://0001-m4-Use-autconf-provided-AC_FUNC_FSEEKO.patch" |
Andrew Geissler | 3eeda90 | 2023-05-19 10:14:02 -0500 | [diff] [blame] | 16 | SRCREV = "920f79206ff59f30a4cff22c9c9c393508b82663" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 17 | |
| 18 | S = "${WORKDIR}/git" |
| 19 | |
| 20 | inherit autotools pkgconfig update-alternatives |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 21 | export ac_cv_sys_file_offset_bits="64" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 22 | |
Andrew Geissler | 3eeda90 | 2023-05-19 10:14:02 -0500 | [diff] [blame] | 23 | EXTRA_OECONF = "--program-prefix= --program-suffix=.im7 --without-perl --enable-largefile" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 24 | |
Andrew Geissler | 3eeda90 | 2023-05-19 10:14:02 -0500 | [diff] [blame] | 25 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)} cxx webp xml" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 26 | PACKAGECONFIG[cxx] = "--with-magick-plus-plus,--without-magick-plus-plus" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 27 | PACKAGECONFIG[graphviz] = "--with-gvc,--without-gvc,graphviz" |
| 28 | PACKAGECONFIG[jp2] = "--with-jp2,,jasper" |
| 29 | PACKAGECONFIG[lzma] = "--with-lzma,--without-lzma,xz" |
| 30 | PACKAGECONFIG[openjpeg] = "--with-openjp2,--without-openjp2,openjpeg" |
| 31 | PACKAGECONFIG[pango] = "--with-pango,--without-pango,pango cairo" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 32 | PACKAGECONFIG[rsvg] = "--with-rsvg,--without-rsvg,librsvg" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 33 | PACKAGECONFIG[tcmalloc] = "--with-tcmalloc=yes,--with-tcmalloc=no,gperftools" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 34 | PACKAGECONFIG[webp] = "--with-webp,--without-webp,libwebp" |
| 35 | PACKAGECONFIG[wmf] = "--with-wmf,--without-wmf,libwmf" |
| 36 | PACKAGECONFIG[x11] = "--with-x,--without-x,virtual/libx11 libxext libxt" |
Andrew Geissler | 3eeda90 | 2023-05-19 10:14:02 -0500 | [diff] [blame] | 37 | PACKAGECONFIG[xml] = "--with-xml,--without-xml,libxml2" |
| 38 | |
| 39 | do_install:append:class-target() { |
| 40 | for file in MagickCore-config.im7 MagickWand-config.im7 Magick++-config.im7; do |
| 41 | sed -i 's,${STAGING_DIR_NATIVE},,g' ${D}${bindir}/"$file" |
| 42 | done |
| 43 | sed -i 's,${S},,g' ${D}${libdir}/ImageMagick-${BASE_PV}/config-Q16HDRI/configure.xml |
| 44 | sed -i 's,${B},,g' ${D}${libdir}/ImageMagick-${BASE_PV}/config-Q16HDRI/configure.xml |
| 45 | sed -i 's,${RECIPE_SYSROOT},,g' ${D}${libdir}/ImageMagick-${BASE_PV}/config-Q16HDRI/configure.xml |
| 46 | sed -i 's,${HOSTTOOLS_DIR},${bindir},g' ${D}${sysconfdir}/ImageMagick-7/delegates.xml |
| 47 | } |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 48 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 49 | FILES:${PN} += "${libdir}/ImageMagick-${BASE_PV}/config-Q16* \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 50 | ${datadir}/ImageMagick-7" |
| 51 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 52 | FILES:${PN}-dev += "${libdir}/ImageMagick-${BASE_PV}/modules-Q16/*/*.a" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 53 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 54 | FILES:${PN}-dbg += "${libdir}/ImageMagick-${BASE_PV}/modules-Q16/*/.debug/*" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 55 | |
| 56 | BBCLASSEXTEND = "native" |
| 57 | |
| 58 | ALTERNATIVE_PRIORITY = "100" |
| 59 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 60 | ALTERNATIVE:${PN} = "animate compare composite conjure convert display \ |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 61 | identify import magick-script mogrify montage stream" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 62 | |
| 63 | ALTERNATIVE_TARGET[animate] = "${bindir}/animate.im7" |
| 64 | ALTERNATIVE_TARGET[compare] = "${bindir}/compare.im7" |
| 65 | ALTERNATIVE_TARGET[composite] = "${bindir}/composite.im7" |
| 66 | ALTERNATIVE_TARGET[conjure] = "${bindir}/conjure.im7" |
| 67 | ALTERNATIVE_TARGET[convert] = "${bindir}/convert.im7" |
| 68 | ALTERNATIVE_TARGET[display] = "${bindir}/display.im7" |
| 69 | ALTERNATIVE_TARGET[identify] = "${bindir}/identify.im7" |
| 70 | ALTERNATIVE_TARGET[import] = "${bindir}/import.im7" |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 71 | ALTERNATIVE_TARGET[magick-script] = "${bindir}/magick-script.im7" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 72 | ALTERNATIVE_TARGET[mogrify] = "${bindir}/mogrify.im7" |
| 73 | ALTERNATIVE_TARGET[montage] = "${bindir}/montage.im7" |
| 74 | ALTERNATIVE_TARGET[stream] = "${bindir}/stream.im7" |
| 75 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 76 | ALTERNATIVE:${PN}-doc = "animate.1 compare.1 composite.1 conjure.1 \ |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 77 | convert.1 display.1 identify.1 import.1 magick-script.1 mogrify.1 montage.1 stream.1" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 78 | |
| 79 | ALTERNATIVE_LINK_NAME[animate.1] = "${mandir}/man1/animate.1" |
| 80 | ALTERNATIVE_TARGET[animate.1] = "${mandir}/man1/animate.im7.1" |
| 81 | ALTERNATIVE_LINK_NAME[compare.1] = "${mandir}/man1/compare.1" |
| 82 | ALTERNATIVE_TARGET[compare.1] = "${mandir}/man1/compare.im7.1" |
| 83 | ALTERNATIVE_LINK_NAME[composite.1] = "${mandir}/man1/composite.1" |
| 84 | ALTERNATIVE_TARGET[composite.1] = "${mandir}/man1/composite.im7.1" |
| 85 | ALTERNATIVE_LINK_NAME[conjure.1] = "${mandir}/man1/conjure.1" |
| 86 | ALTERNATIVE_TARGET[conjure.1] = "${mandir}/man1/conjure.im7.1" |
| 87 | ALTERNATIVE_LINK_NAME[convert.1] = "${mandir}/man1/convert.1" |
| 88 | ALTERNATIVE_TARGET[convert.1] = "${mandir}/man1/convert.im7.1" |
| 89 | ALTERNATIVE_LINK_NAME[display.1] = "${mandir}/man1/display.1" |
| 90 | ALTERNATIVE_TARGET[display.1] = "${mandir}/man1/display.im7.1" |
| 91 | ALTERNATIVE_LINK_NAME[identify.1] = "${mandir}/man1/identify.1" |
| 92 | ALTERNATIVE_TARGET[identify.1] = "${mandir}/man1/identify.im7.1" |
| 93 | ALTERNATIVE_LINK_NAME[import.1] = "${mandir}/man1/import.1" |
| 94 | ALTERNATIVE_TARGET[import.1] = "${mandir}/man1/import.im7.1" |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 95 | ALTERNATIVE_LINK_NAME[magick-script.1] = "${mandir}/man1/magick-script.1" |
| 96 | ALTERNATIVE_TARGET[magick-script.1] = "${mandir}/man1/magick-script.im7.1" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 97 | ALTERNATIVE_LINK_NAME[mogrify.1] = "${mandir}/man1/mogrify.1" |
| 98 | ALTERNATIVE_TARGET[mogrify.1] = "${mandir}/man1/mogrify.im7.1" |
| 99 | ALTERNATIVE_LINK_NAME[montage.1] = "${mandir}/man1/montage.1" |
| 100 | ALTERNATIVE_TARGET[montage.1] = "${mandir}/man1/montage.im7.1" |
| 101 | ALTERNATIVE_LINK_NAME[stream.1] = "${mandir}/man1/stream.1" |
| 102 | ALTERNATIVE_TARGET[stream.1] = "${mandir}/man1/stream.im7.1" |