Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | # |
| 2 | # Copyright (C) 2012 Wind River Systems, Inc. |
| 3 | # |
| 4 | SUMMARY = "MCE test suite" |
| 5 | |
| 6 | DESCRIPTION = "The MCE test suite is a collection of tools and test scripts for \ |
| 7 | testing the Linux RAS related features, including CPU/Memory error \ |
| 8 | containment and recovery, ACPI/APEI support etc." |
| 9 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 10 | LICENSE = "GPL-2.0-only" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 11 | LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3" |
| 12 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 13 | SRC_URI = "git://git.kernel.org/pub/scm/utils/cpu/mce/mce-test.git;protocol=git;branch=master \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 14 | file://makefile-remove-ldflags.patch \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 15 | file://0001-gcov_merge.py-scov_merge.py-switch-to-python3.patch \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 16 | " |
Patrick Williams | e760df8 | 2023-05-26 11:10:49 -0500 | [diff] [blame] | 17 | SRCREV = "025014dedca39d2b8a57a82e52286e72e157d73a" |
| 18 | PV = "20222810+git${SRCPV}" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 19 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 20 | RDEPENDS:${PN} = "mcelog mce-inject dialog bash" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 21 | |
| 22 | COMPATIBLE_HOST = '(i.86|x86_64).*-linux' |
| 23 | |
| 24 | S ="${WORKDIR}/git" |
| 25 | |
Patrick Williams | e760df8 | 2023-05-26 11:10:49 -0500 | [diff] [blame] | 26 | EXTRA_OEMAKE += "CFLAGS='${CFLAGS}'" |
| 27 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 28 | do_install:append(){ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 29 | install -d ${D}/opt/mce-test |
| 30 | cp -rf ${S}/* ${D}/opt/mce-test/ |
| 31 | } |
| 32 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 33 | FILES:${PN} += "/opt" |