Patrick Williams | 169d7bc | 2024-01-05 11:33:25 -0600 | [diff] [blame^] | 1 | SUMMARY = "Dool is a Python3 compatible fork of Dstat" |
| 2 | DESCRIPTION = "Dool is a command line tool to monitor many aspects of your system: \ |
| 3 | CPU, Memory, Network, Load Average, etc. It also includes a robust plug-in architecture \ |
| 4 | to allow monitoring other system metrics." |
| 5 | HOMEPAGE = "http://dag.wiee.rs/home-made/dstat" |
| 6 | LICENSE = "GPL-3.0-only" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=1ebbd3e34237af26da5dc08a4e440464" |
| 8 | |
| 9 | DEPENDS += "asciidoc-native xmlto-native" |
| 10 | RDEPENDS:${PN} += "python3-core python3-misc python3-resource python3-shell python3-six python3-unixadmin" |
| 11 | |
| 12 | SRC_URI = "git://github.com/scottchiefbaker/dool.git;branch=master;protocol=https \ |
| 13 | " |
| 14 | |
| 15 | SRCREV = "30847c748483bc088549486292232d805b086b1f" |
| 16 | |
| 17 | S = "${WORKDIR}/git" |
| 18 | |
| 19 | do_install() { |
| 20 | oe_runmake 'DESTDIR=${D}' install |
| 21 | } |
| 22 | |
| 23 | |