blob: b20f8b40150e39c081d00305ab69e36f4f97d741 [file] [log] [blame]
Patrick Williams169d7bc2024-01-05 11:33:25 -06001SUMMARY = "Dool is a Python3 compatible fork of Dstat"
2DESCRIPTION = "Dool is a command line tool to monitor many aspects of your system: \
3CPU, Memory, Network, Load Average, etc. It also includes a robust plug-in architecture \
4to allow monitoring other system metrics."
5HOMEPAGE = "http://dag.wiee.rs/home-made/dstat"
6LICENSE = "GPL-3.0-only"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=1ebbd3e34237af26da5dc08a4e440464"
8
9DEPENDS += "asciidoc-native xmlto-native"
10RDEPENDS:${PN} += "python3-core python3-misc python3-resource python3-shell python3-six python3-unixadmin"
11
12SRC_URI = "git://github.com/scottchiefbaker/dool.git;branch=master;protocol=https \
13 "
14
15SRCREV = "30847c748483bc088549486292232d805b086b1f"
16
17S = "${WORKDIR}/git"
18
19do_install() {
20 oe_runmake 'DESTDIR=${D}' install
21}
22
23