blob: fe210d5107aaccb34f7fb1c103ddc18778c7594c [file] [log] [blame]
Andrew Geisslereef63862021-01-29 15:58:13 -06001DESCRIPTION = "A regular expression library"
2HOMEPAGE = "https://github.com/google/re2/"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=3b5c31eb512bdf3cb11ffd5713963760"
5
Andrew Geisslerfc113ea2023-03-31 09:59:46 -05006# tag 2023-03-01
7SRCREV = "241e2e430836e80f93d704d1f06cd3e7fe3100f5"
Andrew Geisslereef63862021-01-29 15:58:13 -06008
Patrick Williamsac13d5f2023-11-24 18:59:46 -06009SRC_URI = "git://github.com/google/re2.git;branch=main;protocol=https \
10 ${@bb.utils.contains('PTEST_ENABLED', '1', 'file://run-ptest', '', d)} \
11 "
Andrew Geisslereef63862021-01-29 15:58:13 -060012
13S = "${WORKDIR}/git"
14
Patrick Williamsac13d5f2023-11-24 18:59:46 -060015inherit cmake ptest
16RDEPENDS:${PN}-ptest += "cmake sed"
Andrew Geisslereef63862021-01-29 15:58:13 -060017
18EXTRA_OECMAKE += " \
19 -DBUILD_SHARED_LIBS=ON \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060020 ${@bb.utils.contains('PTEST_ENABLED', '1', '-DRE2_BUILD_TESTING=ON', '-DRE2_BUILD_TESTING=OFF', d)} \
Andrew Geisslereef63862021-01-29 15:58:13 -060021"
22
Patrick Williamsac13d5f2023-11-24 18:59:46 -060023do_install_ptest () {
24 cp -r ${B}/*_test ${D}${PTEST_PATH}
25 cp -r ${B}/CTestTestfile.cmake ${D}${PTEST_PATH}
26 sed -i -e 's#${B}#${PTEST_PATH}#g' `find ${D}${PTEST_PATH} -name CTestTestfile.cmake`
27 sed -i -e 's#${S}#${PTEST_PATH}#g' `find ${D}${PTEST_PATH} -name CTestTestfile.cmake`
28}
29
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050030# ignore .so in /usr/lib64
Patrick Williams213cb262021-08-07 19:21:33 -050031FILES:${PN} = "${libdir}"
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050032INSANE_SKIP:${PN} += "dev-so"
33
34# Don't include so files in dev package
Patrick Williams213cb262021-08-07 19:21:33 -050035FILES:${PN}-dev = "${includedir} ${libdir}/cmake"
Andrew Geisslereef63862021-01-29 15:58:13 -060036
37BBCLASSEXTEND = "native nativesdk"