Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | DESCRIPTION = "CAN BUS tools in Python 3." |
| 2 | HOMEPAGE = "https://github.com/eerimoq/cantools" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d9aa4ec07de78abae21c490c9ffe61bd" |
| 5 | |
Patrick Williams | 169d7bc | 2024-01-05 11:33:25 -0600 | [diff] [blame^] | 6 | SRC_URI[sha256sum] = "98c4d007a6d9803c6433c743c0240e73de930530f8255e1e21d2e20e8991a30b" |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 7 | |
| 8 | PYPI_PACKAGE = "cantools" |
| 9 | |
| 10 | inherit pypi python_poetry_core |
| 11 | |
Patrick Williams | 169d7bc | 2024-01-05 11:33:25 -0600 | [diff] [blame^] | 12 | DEPENDS += "python3-setuptools-scm-native" |
| 13 | |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 14 | RDEPENDS:${PN} += "\ |
| 15 | ${PYTHON_PN}-can \ |
| 16 | ${PYTHON_PN}-bitstruct \ |
| 17 | ${PYTHON_PN}-core \ |
| 18 | ${PYTHON_PN}-textparser \ |
| 19 | ${PYTHON_PN}-typing-extensions \ |
| 20 | ${PYTHON_PN}-diskcache \ |
| 21 | ${PYTHON_PN}-asyncio \ |
| 22 | " |
| 23 | |
| 24 | CLEANBROKEN = "1" |