Patrick Williams | 169d7bc | 2024-01-05 11:33:25 -0600 | [diff] [blame^] | 1 | SUMMARY = "Parse strings using a specification based on the Python format() syntax" |
| 2 | HOMEPAGE = "https://github.com/r1chardj0n3s/parse" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=8ab458ad281b60e6f1b39b3feafbfc05" |
| 5 | |
| 6 | SRC_URI[sha256sum] = "bd28bae37714b45d5894d77160a16e2be36b64a3b618c81168b3684676aa498b" |
| 7 | |
| 8 | SRC_URI += " \ |
| 9 | file://run-ptest \ |
| 10 | " |
| 11 | |
| 12 | inherit pypi python_setuptools_build_meta ptest |
| 13 | |
| 14 | RDEPENDS:${PN} += "\ |
| 15 | python3-datetime \ |
| 16 | python3-logging \ |
| 17 | python3-numbers \ |
| 18 | " |
| 19 | |
| 20 | RDEPENDS:${PN}-ptest += " \ |
| 21 | python3-pytest \ |
| 22 | " |
| 23 | |
| 24 | do_install_ptest() { |
| 25 | cp -f ${S}/tests/test*.py ${D}${PTEST_PATH}/ |
| 26 | } |