blob: 82709ea08adc8b0de09b0b32c956055e04fdbd8c [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Physical quantities module"
2DESCRIPTION = "Physical quantities Python module"
3HOMEPAGE = "https://github.com/hgrecco/pint"
4SECTION = "devel/python"
5
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=bccf824202692270a1e0829a62e3f47b"
8
9PYPI_PACKAGE := "Pint"
10
Andrew Geissler9aee5002022-03-30 16:27:02 +000011inherit pypi ptest python_setuptools_build_meta
Andrew Geissler595f6302022-01-24 19:11:47 +000012
Patrick Williams169d7bc2024-01-05 11:33:25 -060013SRC_URI[sha256sum] = "e1509b91606dbc52527c600a4ef74ffac12fff70688aff20e9072409346ec9b4"
Andrew Geissler595f6302022-01-24 19:11:47 +000014
15DEPENDS += "python3-setuptools-scm-native"
16
17BBCLASSEXTEND = "native nativesdk"
18
19SRC_URI += " \
20 file://run-ptest \
21"
22
23RDEPENDS:${PN} += " \
24 ${PYTHON_PN}-setuptools \
25 ${PYTHON_PN}-packaging \
26"
27
28RDEPENDS:${PN}-ptest += " \
29 ${PYTHON_PN}-pytest \
30"
31
32do_install_ptest() {
33 install -d ${D}${PTEST_PATH}/testsuite
34 cp -rf ${S}/pint/testsuite/* ${D}${PTEST_PATH}/testsuite/
35}