Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | DESCRIPTION = "Python API for MISP" |
| 2 | HOMEPAGE = "https://github.com/MISP/PyMISP" |
| 3 | LICENSE = "BSD-2-Clause" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a3639cf5780f71b125d3e9d1dc127c20" |
| 5 | |
Patrick Williams | 169d7bc | 2024-01-05 11:33:25 -0600 | [diff] [blame^] | 6 | SRC_URI[sha256sum] = "888e848494e04148c8ff5887f04154a2b40f3065c53d93f9cec65f7ca7171362" |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 7 | |
Patrick Williams | 169d7bc | 2024-01-05 11:33:25 -0600 | [diff] [blame^] | 8 | inherit python_poetry_core pypi |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 9 | |
| 10 | PIP_INSTALL_PACKAGE = "pymisp" |
| 11 | |
| 12 | RDEPENDS:${PN} += " \ |
| 13 | ${PYTHON_PN}-dateutil \ |
| 14 | ${PYTHON_PN}-json \ |
| 15 | ${PYTHON_PN}-jsonschema \ |
| 16 | ${PYTHON_PN}-requests \ |
| 17 | ${PYTHON_PN}-six \ |
| 18 | ${PYTHON_PN}-deprecated \ |
| 19 | ${PYTHON_PN}-wrapt \ |
| 20 | " |
| 21 | |
| 22 | # Fixes: python3-pymisp requires /bin/bash, but no |
| 23 | # providers found in RDEPENDS:python3-pymisp? [file-rdep] |
| 24 | RDEPENDS:${PN} += "bash" |