blob: 06b08e78a3c7e0ce95d5ffb1f5b50e3044192f07 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Supervisor: A Process Control System"
2DESCRIPTION = "\
3Supervisor is a client/server system that allows its users \
4to monitorand control a number of processes on UNIX-like \
5operating systems."
6HOMEPAGE = "https://github.com/Supervisor/supervisor"
7LICENSE = "BSD-4-Clause"
8LIC_FILES_CHKSUM = "file://LICENSES.txt;md5=5b4e3a2172bba4c47cded5885e7e507e"
9
10SRC_URI[sha256sum] = "34761bae1a23c58192281a5115fb07fbf22c9b0133c08166beffc70fed3ebc12"
11
12PYPI_PACKAGE = "supervisor"
13inherit pypi systemd setuptools3
14RDEPENDS:${PN} = "\
15 python3-meld3 \
16 python3-io \
17 python3-xmlrpc \
18 python3-resource \
19 python3-setuptools \
Andrew Geissler517393d2023-01-13 08:55:19 -060020"
21
22SRC_URI += "file://supervisord.conf \
23 file://supervisor.service \
24 "
25SYSTEMD_SERVICE:${PN} = "supervisor.service"
26
27do_install:append() {
28 install -d ${D}${sysconfdir}/supervisor
29 install -d ${D}${systemd_system_unitdir}
30
31 install -m 0644 ${WORKDIR}/supervisord.conf ${D}${sysconfdir}/supervisor
32 install -m 0644 ${WORKDIR}/supervisor.service ${D}${systemd_system_unitdir}
33}