Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "Package manager forked from Yum, using libsolv as a dependency resolver" |
| 2 | DESCRIPTION = "Software package manager that installs, updates, and removes \ |
| 3 | packages on RPM-based Linux distributions. It automatically computes \ |
| 4 | dependencies and determines the actions required to install packages." |
| 5 | HOMEPAGE = "https://github.com/rpm-software-management/dnf" |
| 6 | LICENSE = "GPL-2.0-only" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 8 | file://PACKAGE-LICENSING;md5=4a0548e303dbc77f067335b4d688e745 \ |
| 9 | " |
| 10 | |
| 11 | SRC_URI = "git://github.com/rpm-software-management/dnf.git;branch=master;protocol=https \ |
| 12 | file://0001-Corretly-install-tmpfiles.d-configuration.patch \ |
| 13 | file://0001-Do-not-hardcode-etc-and-systemd-unit-directories.patch \ |
| 14 | file://0005-Do-not-prepend-installroot-to-logdir.patch \ |
| 15 | file://0029-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \ |
| 16 | file://0030-Run-python-scripts-using-env.patch \ |
| 17 | file://0001-set-python-path-for-completion_helper.patch \ |
| 18 | " |
| 19 | |
| 20 | SRC_URI:append:class-native = "file://0001-dnf-write-the-log-lock-to-root.patch" |
| 21 | |
Patrick Williams | 169d7bc | 2024-01-05 11:33:25 -0600 | [diff] [blame^] | 22 | SRCREV = "1c43d0999178d492381ad0b43917ffd9c74016f8" |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 23 | UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)" |
| 24 | |
| 25 | S = "${WORKDIR}/git" |
| 26 | |
| 27 | inherit cmake gettext bash-completion setuptools3-base systemd |
| 28 | |
| 29 | DEPENDS += "libdnf librepo libcomps python3-iniparse" |
| 30 | |
| 31 | # manpages generation requires http://www.sphinx-doc.org/ |
| 32 | EXTRA_OECMAKE = " -DWITH_MAN=0 -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3" |
| 33 | |
| 34 | BBCLASSEXTEND = "native nativesdk" |
| 35 | |
| 36 | RDEPENDS:${PN} += " \ |
| 37 | python3-core \ |
| 38 | python3-codecs \ |
| 39 | python3-netclient \ |
| 40 | python3-email \ |
| 41 | python3-threading \ |
| 42 | python3-logging \ |
| 43 | python3-fcntl \ |
| 44 | librepo \ |
| 45 | python3-shell \ |
| 46 | libcomps \ |
| 47 | libdnf \ |
| 48 | python3-sqlite3 \ |
| 49 | python3-compression \ |
| 50 | python3-rpm \ |
| 51 | python3-iniparse \ |
| 52 | python3-json \ |
| 53 | python3-curses \ |
| 54 | python3-misc \ |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 55 | " |
| 56 | |
| 57 | RDEPENDS:${PN}:class-native = "" |
| 58 | |
| 59 | RRECOMMENDS:${PN}:class-target += "gnupg" |
| 60 | |
| 61 | # Create a symlink called 'dnf' as 'make install' does not do it, but |
| 62 | # .spec file in dnf source tree does (and then Fedora and dnf documentation |
| 63 | # says that dnf binary is plain 'dnf'). |
| 64 | do_install:append() { |
| 65 | ln -rs ${D}/${bindir}/dnf-3 ${D}/${bindir}/dnf |
| 66 | ln -rs ${D}/${bindir}/dnf-automatic-3 ${D}/${bindir}/dnf-automatic |
| 67 | } |
| 68 | |
| 69 | # Direct dnf-native to read rpm configuration from our sysroot, not the one it was compiled in |
| 70 | do_install:append:class-native() { |
| 71 | create_wrapper ${D}/${bindir}/dnf \ |
| 72 | RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm \ |
| 73 | RPM_NO_CHROOT_FOR_SCRIPTS=1 |
| 74 | } |
| 75 | |
| 76 | do_install:append:class-nativesdk() { |
| 77 | create_wrapper ${D}/${bindir}/dnf \ |
| 78 | RPM_CONFIGDIR=${SDKPATHNATIVE}${libdir_nativesdk}/rpm \ |
| 79 | RPM_NO_CHROOT_FOR_SCRIPTS=1 |
| 80 | } |
| 81 | |
| 82 | SYSTEMD_SERVICE:${PN} = "dnf-makecache.service dnf-makecache.timer \ |
| 83 | dnf-automatic.service dnf-automatic.timer \ |
| 84 | dnf-automatic-download.service dnf-automatic-download.timer \ |
| 85 | dnf-automatic-install.service dnf-automatic-install.timer \ |
| 86 | dnf-automatic-notifyonly.service dnf-automatic-notifyonly.timer \ |
| 87 | " |
| 88 | SYSTEMD_AUTO_ENABLE ?= "disable" |
| 89 | |
| 90 | SKIP_RECIPE[dnf] ?= "${@bb.utils.contains('PACKAGE_CLASSES', 'package_rpm', '', 'does not build without package_rpm in PACKAGE_CLASSES due disabled rpm support in libsolv', d)}" |
| 91 | |
| 92 | # Packages for testing purposes |
| 93 | PACKAGES += "${PN}-test-main ${PN}-test-dep" |
| 94 | ALLOW_EMPTY:${PN}-test-main = "1" |
| 95 | ALLOW_EMPTY:${PN}-test-dep = "1" |
| 96 | RRECOMMENDS:${PN}-test-main = "${PN}-test-dep" |