Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "ACPICA tools for the development and debug of ACPI tables" |
| 2 | DESCRIPTION = "The ACPI Component Architecture (ACPICA) project provides an \ |
| 3 | OS-independent reference implementation of the Advanced Configuration and \ |
| 4 | Power Interface Specification (ACPI). ACPICA code contains those portions of \ |
| 5 | ACPI meant to be directly integrated into the host OS as a kernel-resident \ |
| 6 | subsystem, and a small set of tools to assist in developing and debugging \ |
| 7 | ACPI tables." |
| 8 | |
Patrick Williams | 2a25492 | 2023-08-11 09:48:11 -0500 | [diff] [blame] | 9 | HOMEPAGE = "https://www.intel.com/content/www/us/en/developer/topic-technology/open/acpica/overview.html" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 10 | SECTION = "console/tools" |
| 11 | |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 12 | LICENSE = "Intel | BSD-3-Clause | GPL-2.0-only" |
Patrick Williams | 44b3caf | 2024-04-12 16:51:14 -0500 | [diff] [blame] | 13 | LIC_FILES_CHKSUM = "file://source/compiler/aslcompile.c;beginline=7;endline=150;md5=05eb845b15a27440410f456adc2ed082" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 14 | |
| 15 | COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux" |
| 16 | |
| 17 | DEPENDS = "m4-native flex-native bison-native" |
| 18 | |
Patrick Williams | 44b3caf | 2024-04-12 16:51:14 -0500 | [diff] [blame] | 19 | SRC_URI = "git://github.com/acpica/acpica;protocol=https;branch=master" |
| 20 | SRCREV = "170fc3076a86777077637f10b05c32ac21ac13aa" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 21 | |
Patrick Williams | 44b3caf | 2024-04-12 16:51:14 -0500 | [diff] [blame] | 22 | S = "${WORKDIR}/git" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 23 | |
| 24 | inherit update-alternatives |
| 25 | |
| 26 | ALTERNATIVE_PRIORITY = "100" |
| 27 | ALTERNATIVE:${PN} = "acpixtract acpidump" |
| 28 | |
| 29 | EXTRA_OEMAKE = "CC='${CC}' \ |
| 30 | OPT_CFLAGS=-Wall \ |
| 31 | DESTDIR=${D} \ |
| 32 | PREFIX=${prefix} \ |
| 33 | INSTALLDIR=${bindir} \ |
| 34 | INSTALLFLAGS= \ |
| 35 | YACC=bison \ |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 36 | YFLAGS='-y --file-prefix-map=${WORKDIR}=${TARGET_DBGSRC_DIR}' \ |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 37 | " |
| 38 | |
| 39 | do_install() { |
| 40 | oe_runmake install |
| 41 | } |
| 42 | |
| 43 | # iasl*.bb is a subset of this recipe, so RREPLACE it |
| 44 | PROVIDES = "iasl" |
| 45 | RPROVIDES:${PN} += "iasl" |
| 46 | RREPLACES:${PN} += "iasl" |
| 47 | RCONFLICTS:${PN} += "iasl" |
| 48 | |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 49 | BBCLASSEXTEND = "native nativesdk" |