blob: 6ac86fc7a1ae54f9db7f4fd342bd39f6b4d2498d [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Python interface to libarchive"
2DESCRIPTION = "A Python interface to libarchive. It uses the standard ctypes module to \
3 dynamically load and access the C library."
4HOMEPAGE = "https://github.com/Changaco/python-libarchive-c"
5LICENSE = "CC0-1.0"
6LIC_FILES_CHKSUM = "file://LICENSE.md;md5=bcab380227a83bc147350b40a81e6ffc"
7
8PYPI_PACKAGE = "libarchive-c"
9
10inherit pypi setuptools3
11
Andrew Geissler220dafd2023-10-04 10:18:08 -050012SRC_URI[sha256sum] = "d673f56673d87ec740d1a328fa205cafad1d60f5daca4685594deb039d32b159"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000013
14RDEPENDS:${PN} += "\
15 libarchive \
Patrick Williams73bd93f2024-02-20 08:07:48 -060016 python3-ctypes \
17 python3-mmap \
18 python3-logging \
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000019"
20
21BBCLASSEXTEND = "native"