blob: c37330eb4c6cf26331aa0292a38fe24bccb81f3a [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "The RPM package management system"
2DESCRIPTION = "The RPM Package Manager (RPM) is a powerful command line driven \
3package management system capable of installing, uninstalling, \
4verifying, querying, and updating software packages. Each software \
5package consists of an archive of files along with information about \
6the package like its version, a description, etc."
7
8SUMMARY_${PN}-dev = "Development files for manipulating RPM packages"
9DESCRIPTION_${PN}-dev = "This package contains the RPM C library and header files. These \
10development files will simplify the process of writing programs that \
11manipulate RPM packages and databases. These files are intended to \
12simplify the process of creating graphical package managers or any \
13other tools that need an intimate knowledge of RPM packages in order \
14to function."
15
16SUMMARY_python3-rpm = "Python bindings for apps which will manupulate RPM packages"
17DESCRIPTION_python3-rpm = "The python3-rpm package contains a module that permits applications \
18written in the Python programming language to use the interface \
19supplied by the RPM Package Manager libraries."
20
21HOMEPAGE = "http://www.rpm.org"
22
23# libraries are also LGPL - how to express this?
24LICENSE = "GPL-2.0"
25LIC_FILES_CHKSUM = "file://COPYING;md5=c0bf017c0fd1920e6158a333acabfd4a"
26
27SRC_URI = "git://github.com/rpm-software-management/rpm;branch=rpm-4.14.x \
28 file://0001-Do-not-add-an-unsatisfiable-dependency-when-building.patch \
29 file://0001-Do-not-read-config-files-from-HOME.patch \
30 file://0001-When-cross-installing-execute-package-scriptlets-wit.patch \
31 file://0001-Do-not-reset-the-PATH-environment-variable-before-ru.patch \
32 file://0002-Add-support-for-prefixing-etc-from-RPM_ETCCONFIGDIR-.patch \
33 file://0001-Do-not-hardcode-lib-rpm-as-the-installation-path-for.patch \
34 file://0001-Fix-build-with-musl-C-library.patch \
35 file://0001-Add-a-color-setting-for-mips64_n32-binaries.patch \
36 file://0011-Do-not-require-that-ELF-binaries-are-executable-to-b.patch \
37 file://0001-Split-binary-package-building-into-a-separate-functi.patch \
38 file://0002-Run-binary-package-creation-via-thread-pools.patch \
39 file://0003-rpmstrpool.c-make-operations-over-string-pools-threa.patch \
40 file://0004-build-pack.c-remove-static-local-variables-from-buil.patch \
41 file://0001-perl-disable-auto-reqs.patch \
42 file://0001-rpm-rpmio.c-restrict-virtual-memory-usage-if-limit-s.patch \
43 file://0016-rpmscript.c-change-logging-level-around-scriptlets-t.patch \
Brad Bishop79641f22019-09-10 07:20:22 -040044 file://0001-mono-find-provides-requires-do-not-use-monodis-from-.patch \
Brad Bishop19323692019-04-05 15:28:33 -040045 "
46
47PE = "1"
48SRCREV = "4a9440006398646583f0d9ae1837dad2875013aa"
49
50S = "${WORKDIR}/git"
51
52DEPENDS = "nss libarchive db file popt xz bzip2 dbus elfutils python3"
53DEPENDS_append_class-native = " file-replacement-native bzip2-replacement-native"
54
55inherit autotools gettext pkgconfig python3native
56export PYTHON_ABI
57
58# OE-core patches autoreconf to additionally run gnu-configize, which fails with this recipe
59EXTRA_AUTORECONF_append = " --exclude=gnu-configize"
60
61EXTRA_OECONF_append = " --without-lua --enable-python"
62EXTRA_OECONF_append_libc-musl = " --disable-nls"
63
64# --sysconfdir prevents rpm from attempting to access machine-specific configuration in sysroot/etc; we need to have it in rootfs
65#
66# --localstatedir prevents rpm from writing its database to native sysroot when building images
67#
68# Disable dbus for native, so that rpm doesn't attempt to inhibit shutdown via session dbus even when plugins support is enabled.
69# Also disable plugins by default for native.
70EXTRA_OECONF_append_class-native = " --sysconfdir=/etc --localstatedir=/var --disable-plugins"
71EXTRA_OECONF_append_class-nativesdk = " --sysconfdir=/etc --localstatedir=/var --disable-plugins"
72
73BBCLASSEXTEND = "native nativesdk"
74
75PACKAGECONFIG ??= ""
76PACKAGECONFIG[imaevm] = "--with-imaevm,,ima-evm-utils"
77
78ASNEEDED = ""
79
80# Direct rpm-native to read configuration from our sysroot, not the one it was compiled in
81# libmagic also has sysroot path contamination, so override it
82
83WRAPPER_TOOLS = " \
84 ${bindir}/rpm \
85 ${bindir}/rpm2archive \
86 ${bindir}/rpm2cpio \
87 ${bindir}/rpmbuild \
88 ${bindir}/rpmdb \
89 ${bindir}/rpmgraph \
90 ${bindir}/rpmkeys \
91 ${bindir}/rpmsign \
92 ${bindir}/rpmspec \
93 ${libdir}/rpm/rpmdeps \
94"
95
96do_install_append_class-native() {
97 for tool in ${WRAPPER_TOOLS}; do
98 create_wrapper ${D}$tool \
99 RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm \
100 RPM_ETCCONFIGDIR=${STAGING_DIR_NATIVE} \
101 MAGIC=${STAGING_DIR_NATIVE}${datadir_native}/misc/magic.mgc \
102 RPM_NO_CHROOT_FOR_SCRIPTS=1
103 done
104}
105
106do_install_append_class-nativesdk() {
107 for tool in ${WRAPPER_TOOLS}; do
108 create_wrapper ${D}$tool \
109 RPM_CONFIGDIR='`dirname $''realpath`'/${@os.path.relpath(d.getVar('libdir'), d.getVar('bindir'))}/rpm \
110 RPM_ETCCONFIGDIR='$'{RPM_ETCCONFIGDIR-'`dirname $''realpath`'/${@os.path.relpath(d.getVar('sysconfdir'), d.getVar('bindir'))}/..} \
111 MAGIC='`dirname $''realpath`'/${@os.path.relpath(d.getVar('datadir'), d.getVar('bindir'))}/misc/magic.mgc \
112 RPM_NO_CHROOT_FOR_SCRIPTS=1
113 done
114
115 rm -rf ${D}/var
116}
117
118# Rpm's make install creates var/tmp which clashes with base-files packaging
119do_install_append_class-target() {
120 rm -rf ${D}/var
121}
122
123do_install_append () {
124 sed -i -e 's:${HOSTTOOLS_DIR}/::g' \
125 ${D}/${libdir}/rpm/macros
126
127 sed -i -e 's|/usr/bin/python|${USRBINPATH}/env ${PYTHON_PN}|' \
128 ${D}${libdir}/rpm/pythondistdeps.py \
129 ${D}${libdir}/rpm/python-macro-helper
130}
131
132FILES_${PN} += "${libdir}/rpm-plugins/*.so \
133 "
134
135FILES_${PN}-dev += "${libdir}/rpm-plugins/*.la \
136 "
137
138PACKAGES += "python3-rpm"
139PROVIDES += "python3-rpm"
140FILES_python3-rpm = "${PYTHON_SITEPACKAGES_DIR}/rpm/*"
141
142# rpm 5.x was packaging the rpm build tools separately
143RPROVIDES_${PN} += "rpm-build"
144
145RDEPENDS_${PN} = "bash perl python3-core"
146
147PACKAGE_PREPROCESS_FUNCS += "rpm_package_preprocess"
148
149# Do not specify a sysroot when compiling on a target.
150rpm_package_preprocess () {
151 sed -i -e 's:--sysroot[^ ]*::g' \
152 ${PKGD}/${libdir}/rpm/macros
153}