Patrick Williams | f52e3dd | 2024-01-26 13:04:43 -0600 | [diff] [blame] | 1 | DESCRIPTION = "Very fast, header only, C++ logging library." |
| 2 | HOMEPAGE = "https://github.com/gabime/spdlog/wiki" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=9573510928429ad0cbe5ba4de77546e9" |
| 5 | |
| 6 | SRCREV = "7c02e204c92545f869e2f04edaab1f19fe8b19fd" |
| 7 | SRC_URI = "git://github.com/gabime/spdlog.git;protocol=https;branch=v1.x" |
| 8 | |
| 9 | DEPENDS = "fmt" |
| 10 | |
| 11 | S = "${WORKDIR}/git" |
| 12 | |
| 13 | inherit cmake |
| 14 | |
| 15 | # no need to build example & tests & benchmarks on pure yocto |
| 16 | EXTRA_OECMAKE += "-DSPDLOG_INSTALL=on -DSPDLOG_BUILD_SHARED=on -DSPDLOG_BUILD_EXAMPLE=off -DSPDLOG_FMT_EXTERNAL=on" |
| 17 | |
| 18 | BBCLASSEXTEND = "native" |