blob: c6a0881db9100c076bbca3b3880447da85c75458 [file] [log] [blame]
Patrick Williamsf52e3dd2024-01-26 13:04:43 -06001DESCRIPTION = "Very fast, header only, C++ logging library."
2HOMEPAGE = "https://github.com/gabime/spdlog/wiki"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=9573510928429ad0cbe5ba4de77546e9"
5
6SRCREV = "7c02e204c92545f869e2f04edaab1f19fe8b19fd"
7SRC_URI = "git://github.com/gabime/spdlog.git;protocol=https;branch=v1.x"
8
9DEPENDS = "fmt"
10
11S = "${WORKDIR}/git"
12
13inherit cmake
14
15# no need to build example & tests & benchmarks on pure yocto
16EXTRA_OECMAKE += "-DSPDLOG_INSTALL=on -DSPDLOG_BUILD_SHARED=on -DSPDLOG_BUILD_EXAMPLE=off -DSPDLOG_FMT_EXTERNAL=on"
17
18BBCLASSEXTEND = "native"