Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Simple top-like I/O monitor" |
| 2 | DESCRIPTION = "iotop does for I/O usage what top(1) does for CPU usage. \ |
| 3 | It watches I/O usage information output by the Linux kernel and displays \ |
| 4 | a table of current I/O usage by processes on the system." |
| 5 | HOMEPAGE = "http://guichaz.free.fr/iotop/" |
| 6 | |
| 7 | |
| 8 | LICENSE = "GPLv2+" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=4325afd396febcb659c36b49533135d4" |
| 10 | |
| 11 | SRC_URI = "http://guichaz.free.fr/iotop/files/${BP}.tar.bz2" |
| 12 | SRC_URI[md5sum] = "5ef9456b26d7694abf3101a72e1e0d1d" |
| 13 | SRC_URI[sha256sum] = "3adea2a24eda49bbbaeb4e6ed2042355b441dbd7161e883067a02bfc8dcef75b" |
| 14 | |
| 15 | inherit distutils |
| 16 | |
| 17 | do_install_append() { |
| 18 | rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/site.pyo || true |
| 19 | rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/site.py || true |
| 20 | } |
| 21 | |
| 22 | RDEPENDS_${PN} = "python-curses python-textutils \ |
| 23 | python-codecs python-ctypes python-pprint \ |
| 24 | python-shell" |