Brad Bishop | 23eaf03 | 2019-11-20 05:15:02 -0500 | [diff] [blame] | 1 | require ${BPN}.inc |
| 2 | |
| 3 | inherit native |
| 4 | |
| 5 | DEPENDS = "glib-2.0-native" |
| 6 | |
| 7 | # build native helpers |
| 8 | do_compile() { |
| 9 | cd ${S}/src/camel |
| 10 | sed -i 's:#include "evolution-data-server-config.h"::g' camel-gen-tables.c |
| 11 | ${CC} -o ${B}/camel-gen-tables camel-gen-tables.c ${CFLAGS} ${LDFLAGS} |
| 12 | |
| 13 | LDFLAGS_glib=`pkg-config glib-2.0 --libs` |
| 14 | CFLAGS_glib=`pkg-config glib-2.0 --cflags` |
| 15 | cd ${S}/src/addressbook/libebook-contacts |
| 16 | sed -i 's:#include "evolution-data-server-config.h"::g' gen-western-table.c |
| 17 | ${CC} -o ${B}/gen-western-table gen-western-table.c ${CFLAGS} ${CFLAGS_glib} ${LDFLAGS} ${LDFLAGS_glib} |
| 18 | } |
| 19 | |
| 20 | do_install() { |
| 21 | install -d ${D}${bindir} |
| 22 | install -m 755 ${B}/* ${D}${bindir} |
| 23 | } |