Andrew Geissler | 26e4bea | 2020-11-30 19:54:03 -0600 | [diff] [blame] | 1 | DESCRIPTION = "Closed source binary files to help boot all raspberry pi devices." |
| 2 | LICENSE = "Broadcom-RPi" |
| 3 | |
| 4 | LIC_FILES_CHKSUM = "file://LICENCE.broadcom;md5=c403841ff2837657b2ed8e5bb474ac8d" |
| 5 | |
| 6 | inherit deploy nopackages |
| 7 | |
| 8 | include recipes-bsp/common/raspberrypi-firmware.inc |
| 9 | |
| 10 | INHIBIT_DEFAULT_DEPS = "1" |
| 11 | |
| 12 | DEPENDS = "rpi-config rpi-cmdline" |
| 13 | |
| 14 | COMPATIBLE_MACHINE = "^rpi$" |
| 15 | |
| 16 | S = "${RPIFW_S}/boot" |
| 17 | |
| 18 | PR = "r3" |
| 19 | |
| 20 | do_deploy() { |
| 21 | install -d ${DEPLOYDIR}/${BOOTFILES_DIR_NAME} |
| 22 | |
| 23 | for i in ${S}/*.elf ; do |
| 24 | cp $i ${DEPLOYDIR}/${BOOTFILES_DIR_NAME} |
| 25 | done |
| 26 | for i in ${S}/*.dat ; do |
| 27 | cp $i ${DEPLOYDIR}/${BOOTFILES_DIR_NAME} |
| 28 | done |
| 29 | for i in ${S}/*.bin ; do |
| 30 | cp $i ${DEPLOYDIR}/${BOOTFILES_DIR_NAME} |
| 31 | done |
| 32 | |
| 33 | # Add stamp in deploy directory |
| 34 | touch ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/${PN}-${PV}.stamp |
| 35 | } |
| 36 | |
| 37 | do_deploy[depends] += "rpi-config:do_deploy rpi-cmdline:do_deploy" |
| 38 | |
| 39 | addtask deploy before do_build after do_install |
| 40 | do_deploy[dirs] += "${DEPLOYDIR}/${BOOTFILES_DIR_NAME}" |
| 41 | |
| 42 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
| 43 | |