Patrick Williams | 53961c2 | 2022-01-20 11:06:23 -0600 | [diff] [blame] | 1 | SUMMARY = "CHIPSEC: Platform Security Assessment Framework" |
| 2 | |
| 3 | DESCRIPTION = "CHIPSEC is a framework for analyzing the security \ |
| 4 | of PC platforms including hardware, system firmware \ |
| 5 | (BIOS/UEFI), and platform components." |
| 6 | |
| 7 | LICENSE = "GPLv2" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=bc2d1f9b427be5fb63f6af9da56f7c5d" |
| 9 | |
| 10 | SRC_URI = "git://github.com/chipsec/chipsec.git;branch=master;protocol=https \ |
| 11 | " |
| 12 | |
| 13 | SRCREV = "b2a61684826dc8b9f622a844a40efea579cd7e7d" |
| 14 | |
| 15 | COMPATIBLE_HOST = "(i.86|x86_64).*-linux" |
| 16 | |
| 17 | S = "${WORKDIR}/git" |
| 18 | EXTRA_OEMAKE = "CC='${CC}' LDFLAGS='${LDFLAGS}' CFLAGS='${CFLAGS}'" |
| 19 | |
| 20 | DEPENDS = "virtual/kernel nasm-native python3-setuptools-native" |
| 21 | RDEPENDS:${PN} += "python3 python3-modules" |
| 22 | |
| 23 | inherit module distutils3 |
| 24 | |
| 25 | do_compile:append() { |
| 26 | cd ${S}/drivers/linux |
| 27 | oe_runmake KSRC=${STAGING_KERNEL_BUILDDIR} |
| 28 | } |
| 29 | |
| 30 | do_install:append() { |
| 31 | install -m 0644 ${S}/drivers/linux/chipsec.ko ${D}${PYTHON_SITEPACKAGES_DIR}/chipsec/helper/linux |
| 32 | } |
| 33 | |
| 34 | FILES:${PN} += "${exec_prefix} \ |
| 35 | " |