blob: b6ea6608eb8b7368e62a6bed541026745c649671 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Provides cryptographic recipes and primitives to python developers"
2HOMEPAGE = "https://cryptography.io/"
3SECTION = "devel/python"
Andrew Geissler8f840682023-07-21 09:09:43 -05004LICENSE = "Apache-2.0 | BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=8c3617db4fb6fae01f1d253ab91511e4 \
Andrew Geissler517393d2023-01-13 08:55:19 -06006 file://LICENSE.APACHE;md5=4e168cce331e5c827d4c2b68a6200e1b \
7 file://LICENSE.BSD;md5=5ae30ba4123bc4f2fa49aa0b0dce887b \
Andrew Geissler517393d2023-01-13 08:55:19 -06008 "
9LDSHARED += "-pthread"
10
Patrick Williams2a254922023-08-11 09:48:11 -050011SRC_URI[sha256sum] = "6d192741113ef5e30d89dcb5b956ef4e1578f304708701b8b73d38e3e1461f34"
Andrew Geissler517393d2023-01-13 08:55:19 -060012
Andrew Geissler8f840682023-07-21 09:09:43 -050013SRC_URI += "file://0001-pyproject.toml-remove-benchmark-disable-option.patch \
14 file://0001-Fix-include-directory-when-cross-compiling-9129.patch \
15 file://check-memfree.py \
16 file://run-ptest \
17 "
Andrew Geissler517393d2023-01-13 08:55:19 -060018
19require ${BPN}-crates.inc
20
Andrew Geissler8f840682023-07-21 09:09:43 -050021inherit pypi python_setuptools3_rust cargo-update-recipe-crates pkgconfig
Andrew Geissler517393d2023-01-13 08:55:19 -060022
23DEPENDS += " \
24 ${PYTHON_PN}-cffi-native \
25"
26
27RDEPENDS:${PN} += " \
28 ${PYTHON_PN}-cffi \
29"
30
31RDEPENDS:${PN}:append:class-target = " \
32 ${PYTHON_PN}-numbers \
33 ${PYTHON_PN}-threading \
34"
35
36RDEPENDS:${PN}-ptest += " \
37 ${PYTHON_PN}-bcrypt \
38 ${PYTHON_PN}-cryptography-vectors (= ${PV}) \
39 ${PYTHON_PN}-hypothesis \
40 ${PYTHON_PN}-iso8601 \
41 ${PYTHON_PN}-pretend \
42 ${PYTHON_PN}-psutil \
43 ${PYTHON_PN}-pytest \
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050044 ${PYTHON_PN}-unittest-automake-output \
Andrew Geissler517393d2023-01-13 08:55:19 -060045 ${PYTHON_PN}-pytest-subtests \
46 ${PYTHON_PN}-pytz \
47"
48
49inherit ptest
50
51do_install_ptest() {
52 install -D ${WORKDIR}/check-memfree.py ${D}${PTEST_PATH}/
53 install -d ${D}${PTEST_PATH}/tests
54 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
55 # remove test_x509.py as it needs benchmark and we don't
56 # want to introduce the benchmark dependency
57 rm -rf ${D}${PTEST_PATH}/tests/bench/test_x509.py
58 install -d ${D}${PTEST_PATH}/tests/hazmat
59 cp -rf ${S}/tests/hazmat/* ${D}${PTEST_PATH}/tests/hazmat/
60 cp -r ${S}/pyproject.toml ${D}${PTEST_PATH}/
61}
62
63FILES:${PN}-ptest += " \
64 ${PTEST_PATH}/check-memfree.py \
65"
66FILES:${PN}-dbg += " \
67 ${PYTHON_SITEPACKAGES_DIR}/${SRCNAME}/hazmat/bindings/.debug \
68"
69
70BBCLASSEXTEND = "native nativesdk"