Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "Cap'n Proto serialization/RPC system" |
| 2 | DESCRIPTION = "Cap’n Proto is an insanely fast data interchange format and capability-based RPC system. " |
| 3 | HOMEPAGE = "https://github.com/sandstorm-io/capnproto" |
| 4 | SECTION = "console/tools" |
| 5 | LICENSE = "MIT" |
| 6 | LIC_FILES_CHKSUM = "file://../LICENSE;md5=a05663ae6cca874123bf667a60dca8c9" |
| 7 | |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 8 | SRC_URI = "git://github.com/sandstorm-io/capnproto.git;branch=release-0.10.4;protocol=https" |
| 9 | SRCREV = "a91ec65323c2577732224d0cf6f5bf1e79d3a724" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 10 | |
| 11 | S = "${WORKDIR}/git/c++" |
| 12 | |
| 13 | inherit cmake |
| 14 | |
| 15 | CXXFLAGS:append:mips = " -latomic" |
| 16 | CXXFLAGS:append:powerpc = " -latomic" |
| 17 | CXXFLAGS:append:riscv32 = " -latomic" |
| 18 | |
| 19 | EXTRA_OECMAKE += "\ |
| 20 | -DBUILD_TESTING=OFF \ |
| 21 | " |
| 22 | |
| 23 | FILES:${PN}-compiler = "${bindir}" |
| 24 | |
| 25 | PACKAGE_BEFORE_PN = "${PN}-compiler" |
| 26 | RDEPENDS:${PN}-dev += "${PN}-compiler" |
| 27 | |
| 28 | BBCLASSEXTEND = "native nativesdk" |