Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | DESCRIPTION = "XML-RPC for C/C++ is programming libraries and related tools to help you \ |
| 2 | write an XML-RPC server or client in C or C++." |
| 3 | |
| 4 | HOMEPAGE = "http://xmlrpc-c.sourceforge.net/" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 5 | LICENSE = "BSD-3-Clause & MIT" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 6 | LIC_FILES_CHKSUM = "file://doc/COPYING;md5=aefbf81ba0750f02176b6f86752ea951" |
| 7 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 8 | SRC_URI = "git://github.com/mirror/xmlrpc-c.git;branch=master;protocol=https \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 9 | file://0001-test-cpp-server_abyss-Fix-build-with-clang-libc.patch \ |
| 10 | file://0002-fix-formatting-issues.patch \ |
| 11 | " |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 12 | #Release 1.59.01 |
| 13 | SRCREV = "352aeaa9ae49e90e55187cbda839f2113df06278" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 14 | |
| 15 | S = "${WORKDIR}/git/stable" |
| 16 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 17 | inherit autotools-brokensep binconfig pkgconfig |
| 18 | |
| 19 | TARGET_CFLAGS += "-Wno-narrowing" |
| 20 | |
| 21 | EXTRA_OEMAKE += "CC_FOR_BUILD='${BUILD_CC}' \ |
| 22 | LD_FOR_BUILD='${BUILD_LD}' \ |
| 23 | CFLAGS_FOR_BUILD='${BUILD_CFLAGS}' \ |
| 24 | LDFLAGS_FOR_BUILD='${BUILD_LDFLAGS}' \ |
| 25 | " |
| 26 | |
| 27 | EXTRA_OECONF += "--disable-libwww-client --disable-wininet-client" |
| 28 | |
| 29 | PACKAGECONFIG ??= "curl cplusplus" |
| 30 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 31 | PACKAGECONFIG[abyss] = "--enable-abyss-server --enable-abyss-threads --enable-abyss-openssl,--disable-abyss-server --disable-abyss-threads --disable-abyss-openssl,openssl" |
| 32 | PACKAGECONFIG[cplusplus] = "--enable-cplusplus,--disable-cplusplus" |
| 33 | PACKAGECONFIG[curl] = "--enable-curl-client,--disable-curl-client,curl" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 34 | |
| 35 | do_configure() { |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 36 | gnu-configize --verbose --force ${S} |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 37 | autoconf |
| 38 | oe_runconf |
| 39 | # license is incompatible with lib/util/getoptx.* |
| 40 | rm -fv ${S}/tools/turbocharger/mod_gzip.c |
| 41 | } |
| 42 | |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 43 | do_install:append:class-target() { |
| 44 | sed -i 's,${WORKDIR},/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR},g' ${D}${bindir}/xmlrpc-c-config |
| 45 | } |
| 46 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 47 | BBCLASSEXTEND = "native" |
| 48 | |
| 49 | CLEANBROKEN = "1" |