Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame^] | 1 | DESCRIPTION = "The volume_key project provides a libvolume_key, a library for manipulating \ |
| 2 | storage volume encryption keys and storing them separately from volumes, and an \ |
| 3 | associated command-line tool, named volume_key." |
| 4 | LICENSE = "GPLv2" |
| 5 | SECTION = "devel/lib" |
| 6 | |
| 7 | HOMEPAGE = "https://pagure.io/volume_key" |
| 8 | |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 10 | |
| 11 | SRC_URI = "https://releases.pagure.org/volume_key/volume_key-${PV}.tar.xz \ |
| 12 | " |
| 13 | SRC_URI[md5sum] = "200591290173c3ea71528411838f9080" |
| 14 | SRC_URI[sha256sum] = "6ca3748fc1dad22c450bbf6601d4e706cb11c5e662d11bb4aeb473a9cd77309b" |
| 15 | |
| 16 | SRCNAME = "volume_key" |
| 17 | S = "${WORKDIR}/${SRCNAME}-${PV}" |
| 18 | |
| 19 | inherit autotools python3native gettext |
| 20 | |
| 21 | DEPENDS += " \ |
| 22 | util-linux \ |
| 23 | glib-2.0 \ |
| 24 | cryptsetup \ |
| 25 | nss \ |
| 26 | gpgme \ |
| 27 | swig-native \ |
| 28 | " |
| 29 | |
| 30 | PACKAGECONFIG ??= "python3" |
| 31 | PACKAGECONFIG[python] = "--with-python,--without-python,python,python" |
| 32 | PACKAGECONFIG[python3] = "--with-python3,--without-python3,python3,python3" |
| 33 | |
| 34 | RDEPENDS_python3-${PN} += "${PN}" |
| 35 | |
| 36 | PACKAGES += "python3-${PN}" |
| 37 | FILES_python3-${PN} = "${PYTHON_SITEPACKAGES_DIR}/*" |
| 38 | |