Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame^] | 1 | # This recipe is modified from the recipe originally found in the Open-Switch |
| 2 | # repository: |
| 3 | # |
| 4 | # https://github.com/open-switch/ops-build |
| 5 | # yocto/openswitch/meta-foss-openswitch/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.0.5.bb |
| 6 | # Commit 9008de2d8e100f3f868c66765742bca9fa98f3f9 |
| 7 | # |
| 8 | # The recipe packaging has been relicensed under the MIT license for inclusion |
| 9 | # in meta-openembedded by agreement of the author (Diego Dompe). |
| 10 | # |
| 11 | |
| 12 | SUMMARY = "Tools to enhance VMWare guest integration and performance" |
| 13 | HOMEPAGE = "https://github.com/vmware/open-vm-tools" |
| 14 | SECTION = "vmware-tools" |
| 15 | |
| 16 | LICENSE = "LGPL-2.0 & GPL-2.0 & BSD & CDDL-1.0" |
| 17 | LIC_FILES_CHKSUM = "file://LICENSE;md5=559317809c5444fb39ceaf6ac45c43ac" |
| 18 | LICENSE_modules/freebsd/vmblock = "BSD" |
| 19 | LICENSE_modules/freebsd/vmmemctl = "GPL-2.0" |
| 20 | LICENSE_modules/freebsd/vmxnet = "GPL-2.0" |
| 21 | LICENSE_modules/linux = "GPL-2.0" |
| 22 | LICENSE_modules/solaris = "CDDL-1.0" |
| 23 | |
| 24 | SRC_URI = "git://github.com/vmware/open-vm-tools.git;protocol=https \ |
| 25 | file://tools.conf \ |
| 26 | file://vmtoolsd.service \ |
| 27 | file://vmtoolsd.init \ |
| 28 | file://0001-configure.ac-don-t-use-dnet-config.patch \ |
| 29 | file://0002-add-include-sys-sysmacros.h.patch \ |
| 30 | file://0005-Use-configure-test-for-struct-timespec.patch \ |
| 31 | file://0006-Fix-definition-of-ALLPERMS-and-ACCESSPERMS.patch \ |
| 32 | file://0007-Use-configure-to-test-for-feature-instead-of-platfor.patch \ |
| 33 | file://0011-Use-configure-test-for-sys-stat.h-include.patch \ |
| 34 | file://fix-subdir-objects-configure-error.patch \ |
| 35 | file://0001-include-poll.h-instead-of-sys-poll.h.patch \ |
| 36 | file://0002-Rename-poll.h-to-vm_poll.h.patch \ |
| 37 | file://0003-use-posix-strerror_r-unless-on-gnu-libc-system.patch \ |
| 38 | file://0004-Use-uintmax_t-for-handling-rlim_t.patch \ |
| 39 | file://0001-Use-off64_t-instead-of-__off64_t.patch \ |
| 40 | file://0001-misc-Do-not-print-NULL-string-into-logs.patch \ |
| 41 | " |
| 42 | # stable-10.3.5 |
| 43 | SRCREV = "f2ff192717375b95a6b7e278fb47dbb3d3bc56d1" |
| 44 | |
| 45 | S = "${WORKDIR}/git/open-vm-tools" |
| 46 | |
| 47 | DEPENDS = "glib-2.0 glib-2.0-native util-linux libdnet procps libtirpc" |
| 48 | |
| 49 | # open-vm-tools is supported only on x86. |
| 50 | COMPATIBLE_HOST = '(x86_64.*|i.86.*)-linux' |
| 51 | |
| 52 | inherit autotools pkgconfig systemd update-rc.d |
| 53 | |
| 54 | SYSTEMD_SERVICE_${PN} = "vmtoolsd.service" |
| 55 | |
| 56 | EXTRA_OECONF = "--without-icu --disable-multimon --disable-docs \ |
| 57 | --disable-tests --without-gtkmm --without-xerces --without-pam \ |
| 58 | --disable-grabbitmqproxy --disable-vgauth --disable-deploypkg \ |
| 59 | --without-root-privileges --without-kernel-modules" |
| 60 | |
| 61 | NO_X11_FLAGS = "--without-x --without-gtk2 --without-gtk3" |
| 62 | X11_DEPENDS = "libxext libxi libxrender libxrandr libxtst gtk+ gdk-pixbuf" |
| 63 | PACKAGECONFIG[x11] = ",${NO_X11_FLAGS},${X11_DEPENDS}" |
| 64 | |
| 65 | # fuse gets implicitly detected; there is no --without-fuse option. |
| 66 | PACKAGECONFIG[fuse] = ",,fuse" |
| 67 | |
| 68 | CFLAGS_append_toolchain-clang = " -Wno-address-of-packed-member" |
| 69 | FILES_${PN} += "\ |
| 70 | ${libdir}/open-vm-tools/plugins/vmsvc/lib*.so \ |
| 71 | ${libdir}/open-vm-tools/plugins/common/lib*.so \ |
| 72 | ${sysconfdir}/vmware-tools/tools.conf \ |
| 73 | " |
| 74 | FILES_${PN}-locale += "${datadir}/open-vm-tools/messages" |
| 75 | FILES_${PN}-dev += "${libdir}/open-vm-tools/plugins/common/lib*.la" |
| 76 | |
| 77 | CONFFILES_${PN} += "${sysconfdir}/vmware-tools/tools.conf" |
| 78 | |
| 79 | RDEPENDS_${PN} = "util-linux libdnet fuse" |
| 80 | |
| 81 | do_install_append() { |
| 82 | ln -sf ${sbindir}/mount.vmhgfs ${D}/sbin/mount.vmhgfs |
| 83 | install -d ${D}${sysconfdir}/vmware-tools |
| 84 | if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then |
| 85 | install -d ${D}${systemd_unitdir}/system |
| 86 | install -m 644 ${WORKDIR}/*.service ${D}${systemd_unitdir}/system |
| 87 | else |
| 88 | install -d ${D}${sysconfdir}/init.d |
| 89 | install -m 0755 ${WORKDIR}/vmtoolsd.init ${D}${sysconfdir}/init.d/vmtoolsd |
| 90 | fi |
| 91 | install -m 0644 ${WORKDIR}/tools.conf ${D}${sysconfdir}/vmware-tools/tools.conf |
| 92 | } |
| 93 | |
| 94 | do_configure_prepend() { |
| 95 | export CUSTOM_DNET_NAME=dnet |
| 96 | export CUSTOM_DNET_LIBS=-L${STAGING_LIBDIR}/libdnet.so |
| 97 | } |
| 98 | |
| 99 | INITSCRIPT_PACKAGES = "${PN}" |
| 100 | INITSCRIPT_NAME_${PN} = "vmtoolsd" |
| 101 | INITSCRIPT_PARAMS_${PN} = "start 90 2 3 4 5 . stop 60 0 1 6 ." |
| 102 | |
| 103 | python() { |
| 104 | if 'networking-layer' not in d.getVar('BBFILE_COLLECTIONS').split() or \ |
| 105 | 'filesystems-layer' not in d.getVar('BBFILE_COLLECTIONS').split(): |
| 106 | raise bb.parse.SkipRecipe('Requires meta-networking and meta-filesystems to be present.') |
| 107 | } |