Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame^] | 1 | SUMMARY = "Smart card library and applications" |
| 2 | DESCRIPTION = "OpenSC is a tool for accessing smart card devices. Basic\ |
| 3 | functionality (e.g. SELECT FILE, READ BINARY) should work on any ISO\ |
| 4 | 7816-4 compatible smart card. Encryption and decryption using private\ |
| 5 | keys on the smart card is possible with PKCS\ |
| 6 | such as the FINEID (Finnish Electronic IDentity) card. Swedish Posten\ |
| 7 | eID cards have also been confirmed to work." |
| 8 | |
| 9 | HOMEPAGE = "http://www.opensc-project.org/opensc/" |
| 10 | SECTION = "System Environment/Libraries" |
| 11 | LICENSE = "LGPLv2+" |
| 12 | LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34" |
| 13 | |
| 14 | #v0.19.0 |
| 15 | SRCREV = "f1691fc91fc113191c3a8aaf5facd6983334ec47" |
| 16 | SRC_URI = "git://github.com/OpenSC/OpenSC \ |
| 17 | file://0001-Remove-redundant-logging.patch \ |
| 18 | " |
| 19 | DEPENDS = "openct pcsc-lite virtual/libiconv openssl" |
| 20 | |
| 21 | S = "${WORKDIR}/git" |
| 22 | inherit autotools pkgconfig bash-completion |
| 23 | |
| 24 | EXTRA_OECONF = " \ |
| 25 | --disable-static \ |
| 26 | --enable-openct \ |
| 27 | --disable-pcsc \ |
| 28 | --disable-ctapi \ |
| 29 | --disable-doc \ |
| 30 | " |
| 31 | EXTRA_OEMAKE = "DESTDIR=${D}" |
| 32 | |
| 33 | RDEPENDS_${PN} = "readline" |
| 34 | |
| 35 | FILES_${PN} += "\ |
| 36 | ${libdir}/opensc-pkcs11.so \ |
| 37 | ${libdir}/onepin-opensc-pkcs11.so \ |
| 38 | ${libdir}/pkcs11-spy.so \ |
| 39 | " |
| 40 | FILES_${PN}-dev += "\ |
| 41 | ${libdir}/pkcs11/opensc-pkcs11.so \ |
| 42 | ${libdir}/pkcs11/onepin-opensc-pkcs11.so \ |
| 43 | ${libdir}/pkcs11/pkcs11-spy.so \ |
| 44 | " |