blob: 7be62cb39426b41d89063cf4bbf75e7e9536368c [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Debugging and profiling extension for PHP"
2LICENSE = "Xdebug"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=92d94a330d34ee6edc2638450736f119"
4
5DEPENDS = "php re2c-native"
6
7SRC_URI = "http://xdebug.org/files/xdebug-${PV}.tgz"
8
9SRC_URI[md5sum] = "e8cabe003d6990b157d0d8caee374844"
10SRC_URI[sha256sum] = "5aa6d1772937e9f11b91ad8ced586aa0e16281dc178c405ac380d45d4731f8b0"
11
12UPSTREAM_CHECK_REGEX = "xdebug-(?P<pver>\d+(\.\d+)+)\.tgz"
13
14inherit autotools
15
16EXTRA_OECONF += "--enable-xdebug -with-php-config=${STAGING_BINDIR_CROSS}/php-config"
17
18do_configure() {
19 cd ${S}
20 ${STAGING_BINDIR_CROSS}/phpize
21 cd ${B}
22
23 # Running autoreconf as autotools_do_configure would do here
24 # breaks the libtool configuration resulting in a failure later
25 # in do_compile. It's possible this may be fixable, however the
26 # easiest course of action for the moment is to avoid doing that.
27 oe_runconf
28}
29
30do_install() {
31 oe_runmake install INSTALL_ROOT=${D}
32}
33
34FILES_${PN} += "${libdir}/php*/extensions/*/*.so"
35FILES_${PN}-dbg += "${libdir}/php*/extensions/*/.debug"